summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-17 14:53:37 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-17 15:18:57 -0800
commitb671f14ce7b506cfc2cf232aecc2929ccc37fc63 (patch)
tree62b3b132a96f369ef883ca0ab3920e301e37d946 /gnome-base
parentgnome-base/gnome-panel: Version bump to 3.42.0 (diff)
downloadgentoo-b671f14ce7b506cfc2cf232aecc2929ccc37fc63.tar.gz
gentoo-b671f14ce7b506cfc2cf232aecc2929ccc37fc63.tar.bz2
gentoo-b671f14ce7b506cfc2cf232aecc2929ccc37fc63.zip
gnome-base/gnome-applets: Version bump to 3.42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-applets/Manifest1
-rw-r--r--gnome-base/gnome-applets/gnome-applets-3.42.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-base/gnome-applets/Manifest b/gnome-base/gnome-applets/Manifest
index 30901def6d3b..343985f5f764 100644
--- a/gnome-base/gnome-applets/Manifest
+++ b/gnome-base/gnome-applets/Manifest
@@ -1 +1,2 @@
DIST gnome-applets-3.40.0.tar.xz 9390340 BLAKE2B 0d8e76086e444789b7a327623db9b21ef0a51f071b67aa5d99dc3e7988be40ec353ced795aaa1acbbe8d1b303d3878e2a0589214dac10f35ab2e40381ee64978 SHA512 909a1e9ecbe6904537b7408239a17aad265890cf179c4b8929968fa4d8ba6f1ac1f6e98612eb9c54266d3abacaaa7ed0e218f41b081b7539532527a3234fc037
+DIST gnome-applets-3.42.0.tar.xz 9391580 BLAKE2B 43d3c86d4c401ef6e509a7ff653c613d7f49624354ea74635f9aa634e33c92bb54cc2461ab8e9fb3fcf7efe3f97fc9a65c9b8f7a0b8fc3e126a531492274518b SHA512 9be26e7779123dc5dc56aabe274d3ee34b3ffea830e2691051bf2a8011a1896c5e56fb9cc6d89b7f5ff14b1aeea969b81134bb7d0e4b1615343bf23daa1137a5
diff --git a/gnome-base/gnome-applets/gnome-applets-3.42.0.ebuild b/gnome-base/gnome-applets/gnome-applets-3.42.0.ebuild
new file mode 100644
index 000000000000..0863ef27e917
--- /dev/null
+++ b/gnome-base/gnome-applets/gnome-applets-3.42.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="Applets for the GNOME Flashback Panel"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-applets/"
+
+LICENSE="GPL-2+ FDL-1.1"
+SLOT="0"
+IUSE="tracker"
+KEYWORDS="~amd64 ~riscv"
+
+# FIXME: automagic wireless-tools
+# TODO: gucharmap could be optional, but no knob
+# TODO: libgweather could be optional, but no knob
+RDEPEND="
+ >=x11-libs/gtk+-3.20.0:3[X]
+ >=dev-libs/glib-2.44.0:2
+ >=gnome-base/gnome-panel-3.41.1
+ >=gnome-base/libgtop-2.11.92:=
+ >=x11-libs/libwnck-3.14.1:3
+ >=x11-libs/libnotify-0.7
+ >=sys-power/upower-0.99.8:=
+ >=x11-themes/adwaita-icon-theme-3.14.0
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/libgweather-40.0:2=
+ >=gnome-extra/gucharmap-2.33.0:2.90
+ >=sys-auth/polkit-0.97
+ x11-libs/libX11
+ tracker? ( app-misc/tracker:3 )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+" # yelp-tools and autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-cpufreq \
+ $(use_enable tracker tracker-search-bar)
+}