summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-05 12:30:20 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-05 12:35:39 +0200
commitbbdb778115af3e9b048503d28557e656bc027f97 (patch)
treed31ce943a2ab70098e7c03d081a7ab07e53a28b1 /gnome-base
parentnet-print/cnrdrvcups-lb: new package for Canon laser printers (diff)
downloadgentoo-bbdb778115af3e9b048503d28557e656bc027f97.tar.gz
gentoo-bbdb778115af3e9b048503d28557e656bc027f97.tar.bz2
gentoo-bbdb778115af3e9b048503d28557e656bc027f97.zip
gnome-base/gnome-menus: bump to 3.32.0
Drop the ignore_kde_standalone.patch stuff, as it seems mostly legacy - there aren't dozens of X-KDE-settings-* desktop files anymore, only some external ones it seems that might not have gotten the memo to remove the category. If this is a problem, it should be fixed properly or worked around in other /etc/xdg/menus files too (gnome-flashback-applications.menu, xfce-applications.menu, etc) Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-menus/Manifest1
-rw-r--r--gnome-base/gnome-menus/gnome-menus-3.32.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/gnome-base/gnome-menus/Manifest b/gnome-base/gnome-menus/Manifest
index 352b5c37f058..44fe9e3d63a8 100644
--- a/gnome-base/gnome-menus/Manifest
+++ b/gnome-base/gnome-menus/Manifest
@@ -1 +1,2 @@
DIST gnome-menus-3.13.3.tar.xz 404664 BLAKE2B 7772c817317b4af86e740aeea3095f51ff210f73e53160ca2359d45a017236c82fe787956c04a9e0001e2511671438d4955f0bf7947cdfa8649d78fe931d6d79 SHA512 d631eb17ddc1b33227d0e5862a9344a8605ee1e9ebc1f12ce4ac98895adaf8a82ef2a49415d99bc194a02f30f30c3d6d49759f280fbc246c9e482711fd5021d2
+DIST gnome-menus-3.32.0.tar.xz 499680 BLAKE2B ee43c2be29f6d3f5eaf5369c3b3809fc2728564321853a6dd23df1d81138868f9be2f57d0bcd0eb69a509e224f77dc357a8c71afe569bfb1bbdb13ce3b80636f SHA512 8a429e092b1e4a1a794473d7cae611684321e797792e1063911ddcbb496140033838b348bc209b4c0566a13233cfa1144cae7a188a483abf34c5af6feb44a884
diff --git a/gnome-base/gnome-menus/gnome-menus-3.32.0.ebuild b/gnome-base/gnome-menus/gnome-menus-3.32.0.ebuild
new file mode 100644
index 000000000000..c9f8efffcd41
--- /dev/null
+++ b/gnome-base/gnome-menus/gnome-menus-3.32.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="Library and layout configuration for the Desktop Menu fd.o specification"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-menus"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="+introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ test? ( dev-libs/gjs )
+"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+
+src_configure() {
+ # Do NOT compile with --disable-debug/--enable-debug=no
+ # It disables api usage checks
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}