summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-08 14:30:12 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-08 14:31:03 +0300
commitca0ad966b82e1cdadd45af81c84bdb25fcf1fcb3 (patch)
tree7bd9de1e5771abc61105a6b19d25ab33278cf806 /gnome-base
parentsys-devel/crossdev: bump up to 20190908 (diff)
downloadgentoo-ca0ad966b82e1cdadd45af81c84bdb25fcf1fcb3.tar.gz
gentoo-ca0ad966b82e1cdadd45af81c84bdb25fcf1fcb3.tar.bz2
gentoo-ca0ad966b82e1cdadd45af81c84bdb25fcf1fcb3.zip
gnome-base/dconf: bump to 0.32.0, drop env.d snippet and vala deps
Long ago we added a /etc/env.d/51dconf for forcing GSETTINGS_BACKEND=dconf into the environment when dconf is installed - presumably to switch over to it from gconf. However nowadays dconf already has the highest priority out of the available gsettings backend extension points, thus this has become long unnecessary, and if GSETTINGS_BACKEND is unset and dconf is installed, it'll pick dconf still too. dconf-0.32 ported its dconf command line utility away from vala to straight C, and thus vala is not necessary anymore. It is necessary (the vapigen.pc file in particular) upstream for finding the location where to install the pregenerated dconf.vapi and dconf.deps files, but I've patched it to just fallback to the well-established location of ${datadir}/vala/vapi/ and thus can keep shipping vapi file without introducing a USE flag and vala deps. Closes: https://bugs.gentoo.org/693472 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf/Manifest1
-rw-r--r--gnome-base/dconf/dconf-0.32.0.ebuild67
-rw-r--r--gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch44
3 files changed, 112 insertions, 0 deletions
diff --git a/gnome-base/dconf/Manifest b/gnome-base/dconf/Manifest
index 62d2bd9733b0..d4f2717e402f 100644
--- a/gnome-base/dconf/Manifest
+++ b/gnome-base/dconf/Manifest
@@ -1,2 +1,3 @@
DIST dconf-0.26.1.tar.xz 218516 BLAKE2B ddb23a1f6519b5460903b1a91ba48242f144a768f7ec5b9e82953589474df998061a4fbfb3605027cb51db44f7e49f88c774a735600de2bedaf8889b58e050bc SHA512 4d2b4afce189e448e3bd4e9c2f9d3d5eec6c694748aec87a9a8de047296c858772a5234dbcace8e84d99c5378d2d1ba35cafb5e5ea7efca25c10a53a55b8b6da
DIST dconf-0.30.1.tar.xz 104376 BLAKE2B c5a90c092b6e028dafbc9aee2f29f622dc4a696e815266355de4a056fe507b0cca9eaa9b10753501ee44f74ee57d0095fd55aafc7205ffea1f0321ed705dbe0b SHA512 f7d136aec7cb75b64c7d9446d520f4c4af368e6d22346b7bb8ad66c08afaa03a72aacd44016dae7690e37b7d0deb9a16187445db176427a12a8b3cd3885c9e03
+DIST dconf-0.32.0.tar.xz 111700 BLAKE2B 51ac54deafc44a56aa6af1bdc8a89e1002772969881870b196a12f85d5b1a090a334b3088b051e07e085b7fe736e2e51479c17ffcc38a18e682b8238d51671ee SHA512 09ae65ad365947aed24228b94978b290060264e55b443d18a743e943627703c92e16e3a5ca8a0aaf3549f7a1d5aad77bdc285d4c8519db705d3104ec22b111a0
diff --git a/gnome-base/dconf/dconf-0.32.0.ebuild b/gnome-base/dconf/dconf-0.32.0.ebuild
new file mode 100644
index 000000000000..2175d3f9748d
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.32.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/Projects/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE="gtk-doc"
+RESTRICT="!test? ( test )" # IUSE=test comes from virtualx.eclass
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ sys-apps/dbus
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ gtk-doc? ( >=dev-util/gtk-doc-1.15 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.30.1-bash-completion-dir.patch
+ "${FILESDIR}"/${PV}-drop-vapigen-dep.patch # .vapi/.deps are pregenerated, just install them without a vala dep
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -Dman=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dvapi=true
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_giomodule_cache_update
+
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_giomodule_cache_update
+}
diff --git a/gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch b/gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch
new file mode 100644
index 000000000000..55959a7febf0
--- /dev/null
+++ b/gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch
@@ -0,0 +1,44 @@
+From 22d4c12d73238d24b91a753c414c5f5a5a9c76b6 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 8 Sep 2019 14:17:20 +0300
+Subject: [PATCH] build: Don't hard require vapigen.pc
+
+.. by having a fallback to the well known location of packages shipped
+vapi files
+---
+ client/meson.build | 12 ++++++++----
+ 1 file changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/client/meson.build b/client/meson.build
+index f3b7122..7dbca97 100644
+--- a/client/meson.build
++++ b/client/meson.build
+@@ -57,17 +57,21 @@ pkg.generate(
+ )
+
+ if get_option('vapi')
+- vapigen_dep = dependency('vapigen')
++ vapigen_dep = dependency('vapigen', required: false)
+
+ vapi_data = files(
+ 'dconf.vapi',
+ 'dconf.deps',
+ )
+
+- vapi_dir = vapigen_dep.get_pkgconfig_variable(
+- 'vapidir',
+- define_variable: ['datadir', dconf_datadir]
++ if vapigen_dep.found()
++ vapi_dir = vapigen_dep.get_pkgconfig_variable(
++ 'vapidir',
++ define_variable: ['datadir', dconf_datadir]
+ )
++ else
++ vapi_dir = dconf_datadir / 'vala' / 'vapi'
++ endif
+
+ install_data(
+ vapi_data,
+--
+2.20.1
+