summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-20 14:18:41 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-20 14:29:55 -0700
commitd1398a3a6e61189db5c5350729cfe8f1354d4daf (patch)
treed547c0b45acd44aa2805202bac8d9852de103128 /gnome-base
parentnet-firewall/iptables: depend on newer eselect-iptables for IPv6 fix (diff)
downloadgentoo-d1398a3a6e61189db5c5350729cfe8f1354d4daf.tar.gz
gentoo-d1398a3a6e61189db5c5350729cfe8f1354d4daf.tar.bz2
gentoo-d1398a3a6e61189db5c5350729cfe8f1354d4daf.zip
gnome-base/librsvg: Version bump to 2.54.0
Bug: https://bugs.gentoo.org/835630 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/Manifest1
-rw-r--r--gnome-base/librsvg/librsvg-2.54.0.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/gnome-base/librsvg/Manifest b/gnome-base/librsvg/Manifest
index 307bbff4a960..a98cc44df5bb 100644
--- a/gnome-base/librsvg/Manifest
+++ b/gnome-base/librsvg/Manifest
@@ -1,3 +1,4 @@
DIST librsvg-2.40.21.tar.xz 1655860 BLAKE2B a3fd7915d39984057e860da90115d9d95cef97e61d3f5e4c3aaaf399c4b3bfe781e6a7b969958ae84a3b7f2c788576fe26f56b037ca0a6a2e059b53f2bd1b9fc SHA512 db0563d8e0edaae642a6b2bcd239cf54191495058ac8c7ff614ebaf88c0e30bd58dbcd41f58d82a9d5ed200ced45fc5bae22f2ed3cf3826e9348a497009e1280
DIST librsvg-2.52.6.tar.xz 23662708 BLAKE2B 21108297aa4f87a852d0decb9cc7b8a5cdb546e00075d16f0f86502752adc176a67b56607eb90b034ca4e2dddbf8f82a3d81727496a5ae1a2b94715cdbbd87ac SHA512 be4830fb34c4859bdbe0c86da7b5de0807f28bb63fc124b4405ca8f9ef6ee45add77b4c43b9031d00157870eceb458df30cf5ee25e73d3894797d622b465f38d
DIST librsvg-2.52.7.tar.xz 23709632 BLAKE2B 4eb83d71b77b851c408ddba711fe39ed23863aa6466634020a19ffc30e00c12f7dea81f11fdc09eb53c0c72efb35adc4528568b3c27e5dc0e886426d145d347f SHA512 15c075d696ebba35555f93456be088e6398da5b7992119edc78f1ee1d376a70425248e36b138dc86234aec13cb139fded11d6d74523c44f9a49eb19c2151fcb7
+DIST librsvg-2.54.0.tar.xz 23489972 BLAKE2B 04fcbb688b18e98dcbef81e84106a99280d45f242152a355ac6f202410c13b289b281bd10f9e77854997362b7d3e88832d3274d7d63ace8adc05613da99e2aab SHA512 3357ca8cf7537fe2792ee2d9a1719622656f3e1d7f30da062799a4b3ca8788cc07333a00e1c9da53a53da2b67a2aa5895a4c8fce35003da659fb7f98048b68eb
diff --git a/gnome-base/librsvg/librsvg-2.54.0.ebuild b/gnome-base/librsvg/librsvg-2.54.0.ebuild
new file mode 100644
index 000000000000..17264842982a
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.54.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION=0.46
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome2 multilib-minimal python-any-r1 rust-toolchain vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibRsvg"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.16.0[glib,svg,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.9:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.20:2[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0.0:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.48.11[${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+"
+DEPEND="${RDEPEND}
+ >=virtual/rust-1.54[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')
+ dev-util/gi-docgen
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# >=gtk-doc-am-1.13, gobject-introspection-common, vala-common needed by eautoreconf
+
+QA_FLAGS_IGNORED="
+ usr/bin/rsvg-convert
+ usr/lib.*/librsvg.*
+"
+
+RESTRICT="test" # Lots of issues on 32bit builds, 64bit build seems to get into an infinite compilation sometimes, etc.
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-static
+ --disable-debug
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable vala)
+ --enable-pixbuf-loader
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # Set the rust target, which can differ from CHOST
+ RUST_TARGET="$(rust_abi)"
+ # RUST_TARGET is only honored if cross_compiling, but non-native ABIs aren't cross as
+ # far as C parts and configure auto-detection are concerned as CHOST equals CBUILD
+ cross_compiling=yes
+ )
+ fi
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PF}/Rsvg-2.0 "${ED}"/usr/share/gtk-doc/html/ || die
+}
+
+pkg_postinst() {
+ multilib_foreach_abi gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ multilib_foreach_abi gnome2_pkg_postrm
+}