summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-10-13 19:25:39 +0300
committerMart Raudsepp <leio@gentoo.org>2019-10-13 19:26:06 +0300
commitd352249b33013f50070aba43dea4cc3f488186db (patch)
tree617e25f034ad48c587fab75fb5c59995e2cde299 /gnome-base
parentgnome-extra/gnome-weather: bump to 3.32.2 (diff)
downloadgentoo-d352249b33013f50070aba43dea4cc3f488186db.tar.gz
gentoo-d352249b33013f50070aba43dea4cc3f488186db.tar.bz2
gentoo-d352249b33013f50070aba43dea4cc3f488186db.zip
gnome-base/dconf-editor: bump to 3.34.2
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf-editor/Manifest1
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.34.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index 8666880e8e4c..3ae4e1bc2456 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1 +1,2 @@
DIST dconf-editor-3.30.2.tar.xz 447060 BLAKE2B 4cd8ab7200afaa402d6915a94be12b32a58fdf11ed77d4b833e3734b94de99bf7182d3564d1e0b42935d4364b2c973c296d773de402942af8e66f4ccbe6026be SHA512 c9fe4393e9c75ad19c56670a50199493a32ed55f3135ada599aef5efb4582320a23648da1906ce1a1b64918987fd3684f00bfc749a21a6fd2806066d760418c8
+DIST dconf-editor-3.34.2.tar.xz 560308 BLAKE2B 9172a4dd77765d067228c6652b004bd6811c71a83bb4191a71ef70181a5e0aa1c3bca6d655c76eb032793eb5c39364ece23337fa86d1a6e31e59391a3554933e SHA512 6c2d89d2d62a768b669ca49e0298bddf4f4151358f0fc0314431c7f926df2323ac3b61540f2a3c95c7b5a88e4e2f08dae4d00f601506c9610a0edee4b00ba499
diff --git a/gnome-base/dconf-editor/dconf-editor-3.34.2.ebuild b/gnome-base/dconf-editor/dconf-editor-3.34.2.ebuild
new file mode 100644
index 000000000000..ab376da8bc88
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.34.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}