summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-18 12:58:10 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-18 13:03:41 -0400
commitf472068d89c18ab5348ee80c6916ca63263f1c8c (patch)
treeb062f0991ab8e04b25d19a3333fcd1b6ac703052 /gnome-base
parentmedia-libs/vips: add 8.14.5 (diff)
downloadgentoo-f472068d89c18ab5348ee80c6916ca63263f1c8c.tar.gz
gentoo-f472068d89c18ab5348ee80c6916ca63263f1c8c.tar.bz2
gentoo-f472068d89c18ab5348ee80c6916ca63263f1c8c.zip
gnome-base/dconf-editor: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32907 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf-editor/Manifest1
-rw-r--r--gnome-base/dconf-editor/dconf-editor-45.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index af599cac9917..ac064acb387a 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1,2 +1,3 @@
DIST dconf-editor-3.38.3.tar.xz 594544 BLAKE2B 0455fc01be96bccec9a9799c5bf23e9fe58cb34d32899a119753f58f5bc2f03acb96ff0eeba131cd8c0ea130e3afad16e4fadb23601510b618bf7a3d5a1664a3 SHA512 cf00705c1e11eab980777b9696fbaaa0f5f8a8118276f2add4f4fcefe5aab46844a539539418ce61f285e65623179a9d63cc18a91339b70b5e7c9408c697e9d1
DIST dconf-editor-43.0.tar.xz 598496 BLAKE2B 16b39289f822075a951514c44c5b5d673dd5c6d7e4f043f8005098a51209513c88a16846a7bb8988696775ad4f44162080edec59e3dfe2402a814573ff4efe85 SHA512 d13d32a982164e6991576039dda54d51508fc56e1119def9b89ca498ac111c98f144309cab42e45d5b77130d4d7d8fa23168865c604cbaf55da4e6ed3d451953
+DIST dconf-editor-45.0.tar.xz 608520 BLAKE2B 257622a60309beedcf5f0202502012a61d691c8a50d6bca3321103108e9a178fdfd5eb6283c9cdf09e9540fabf1b67b25a082caae2412c797f5a53d1f391fa6f SHA512 082b51fcb9c67ec58bfdc27ad6e6fd8f507718450498e2cc9e8688c424c7942af523e3c71efb908bc354a861e2170e8ecaab2f484bfc4300db12613483d8b5ec
diff --git a/gnome-base/dconf-editor/dconf-editor-45.0.ebuild b/gnome-base/dconf-editor/dconf-editor-45.0.ebuild
new file mode 100644
index 000000000000..e2d484fd1c73
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-45.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=gui-libs/libhandy-1.6.0:1[vala]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}