summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2022-12-04 23:30:38 -0500
committerSam James <sam@gentoo.org>2022-12-24 07:04:00 +0000
commit81b676612b410edd241f955455c5292c0dea0c13 (patch)
tree25fdd5e4c7b50a433b4b0c9af2e1e871b78774ea /gnome-extra/cinnamon
parentgnome-extra/nemo: drop 5.6.0 (diff)
downloadgentoo-81b676612b410edd241f955455c5292c0dea0c13.tar.gz
gentoo-81b676612b410edd241f955455c5292c0dea0c13.tar.bz2
gentoo-81b676612b410edd241f955455c5292c0dea0c13.zip
gnome-extra/cinnamon: add 5.6.5
Drop deprecated dependencies. Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra/cinnamon')
-rw-r--r--gnome-extra/cinnamon/Manifest1
-rw-r--r--gnome-extra/cinnamon/cinnamon-5.6.5.ebuild182
2 files changed, 183 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/Manifest b/gnome-extra/cinnamon/Manifest
index 9e1b78ab7b61..34af89fb8afa 100644
--- a/gnome-extra/cinnamon/Manifest
+++ b/gnome-extra/cinnamon/Manifest
@@ -1,2 +1,3 @@
DIST cinnamon-5.2.7.tar.gz 2423949 BLAKE2B f4ce9ec4c79eab3daadff958c0a334d49757548203078ab657ebe2450f3f179c942df9d0f9089efe313c268c929628d724db43371e12338606d284a2738ed62c SHA512 62cbbe2f719574b3f70a4895c231be9ad65a41220d2755cc1557bc06bb2b31ced93621c356f2973376d127d5a1e59f9295498bbc4812d428e8605e8f4882c733
DIST cinnamon-5.6.1.tar.gz 2482117 BLAKE2B 9b7f9f9c045adb1497875d7d735b3d8b684869695c3e476f3f8f671840b31a6bd043c8d9f7aca2ab8d1e3fa90d85da454cb612e16a9489e5bfaa7df590a91d3b SHA512 3ec7ce8cd1b2e98283ab84dd55a7e2e1693f6ad5cc7c6db8241808b9d96ab7c375c8739c470b99a83e3b6560ffcc50c070d2439dea71ab0d0792ef7c3bd8cd38
+DIST cinnamon-5.6.5.tar.gz 2481833 BLAKE2B af7f5010cba9afac9c37aca60f1d6a730fca9bcfe4860a79e8f7cc903cbff45cde4d650530309c4866eeedd52212a4287221e89e5616b3ab0d0903cad3a33afb SHA512 767a68683f2776a1216ec32c479a84203c8524e7bbf2bd65faf4249a46d1a2ccfae8feb55d664890c1b1cd2061895c79d9bec5a70f126b819baebb19804ac30c
diff --git a/gnome-extra/cinnamon/cinnamon-5.6.5.ebuild b/gnome-extra/cinnamon/cinnamon-5.6.5.ebuild
new file mode 100644
index 000000000000..ad95938cfc7d
--- /dev/null
+++ b/gnome-extra/cinnamon/cinnamon-5.6.5.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit meson gnome2-utils pax-utils python-single-r1 xdg
+
+DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon"
+SRC_URI="https://github.com/linuxmint/cinnamon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+ GPL-3+ GPL-3-with-openssl-exception LGPL-2+ LGPL-2.1 LGPL-2.1+ MIT"
+SLOT="0"
+IUSE="+eds +gstreamer gtk-doc +nls +networkmanager"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.52.0:2[dbus]
+ >=dev-libs/gobject-introspection-1.29.15:=
+ dev-libs/libxml2:2
+ >=gnome-extra/cinnamon-desktop-5.6:0=
+ >=gnome-extra/cinnamon-menus-5.6
+ >=gnome-extra/cjs-5.6[cairo]
+ sys-apps/dbus
+ >=sys-auth/polkit-0.100[introspection]
+ virtual/opengl
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.12.0:3[introspection]
+ >=x11-libs/libnotify-0.7.3:0=[introspection]
+ x11-libs/libX11
+ >=x11-libs/libXfixes-5.0
+ x11-libs/pango[introspection]
+ >=x11-libs/xapp-2.4.1[introspection]
+ >=x11-wm/muffin-5.6[introspection]
+
+ eds? (
+ gnome-extra/evolution-data-server
+ )
+ gstreamer? (
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ )
+ networkmanager? (
+ net-misc/networkmanager[introspection]
+ )
+"
+# caribou used by onscreen keyboard
+# libtimezonemap used by datetime settings
+# iso-flag-png (unpackaged) used by keyboard layout settings
+RDEPEND="
+ ${DEPEND}
+ >=app-accessibility/caribou-0.3
+ dev-libs/keybinder:3[introspection]
+ dev-libs/libtimezonemap
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/python-pam[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/python3-xapp-2.4.0[${PYTHON_USEDEP}]
+ ')
+ >=gnome-base/dconf-0.4.1
+ >=gnome-base/gsettings-desktop-schemas-2.91.91
+ >=gnome-base/libgnomekbd-2.91.4
+ >=gnome-extra/cinnamon-control-center-5.6[networkmanager=]
+ >=gnome-extra/cinnamon-screensaver-5.6
+ >=gnome-extra/cinnamon-session-5.6
+ >=gnome-extra/cinnamon-settings-daemon-5.6
+ >=gnome-extra/nemo-5.6
+ gnome-extra/polkit-gnome
+ media-libs/gsound
+ net-libs/libsoup:2.4[introspection]
+ net-misc/wget
+ sys-apps/accountsservice[introspection]
+ sys-apps/coreutils
+ sys-apps/pciutils
+ sys-apps/util-linux
+ sys-power/upower[introspection]
+ x11-misc/xdg-utils
+ x11-themes/adwaita-icon-theme
+ x11-themes/gnome-themes-standard
+
+ nls? (
+ >=gnome-extra/cinnamon-translations-5.6
+ )
+"
+BDEPEND="
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ # Fix backgrounds path as cinnamon doesn't provide them
+ # https://github.com/linuxmint/Cinnamon/issues/3575
+ "${FILESDIR}"/${PN}-3.8.0-gnome-background-compatibility.patch
+
+ # Use wheel group instead of sudo (from Fedora/Arch)
+ # https://github.com/linuxmint/Cinnamon/issues/3576
+ "${FILESDIR}"/${PN}-3.6.6-wheel-sudo.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+
+ # Add polkit agent to required components
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ sed -i "s/'REQUIRED', '/&polkit-cinnamon-authentication-agent-1;/" meson.build || die
+
+ # shebang fixing craziness
+ local p
+ for p in $(grep -rl '#!.*python3' || die); do
+ python_fix_shebang "${p}"
+ done
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gstreamer build_recorder)
+ $(meson_use gtk-doc docs)
+ -Ddisable_networkmanager=$(usex networkmanager false true)
+ -Dpy3modules_dir="$(python_get_sitedir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ python_optimize "${D}$(python_get_sitedir)"
+ python_optimize "${ED}"/usr/share/cinnamon/
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ pax-mark mr "${ED}"/usr/bin/cinnamon
+
+ # Doesn't exist on Gentoo, causing this to be a dead symlink
+ rm "${ED}/etc/xdg/menus/cinnamon-applications-merged" || die
+
+ # Ensure authentication-agent is started, bug #523958
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ insinto /etc/xdg/autostart/
+ doins "${FILESDIR}"/polkit-cinnamon-authentication-agent-1.desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if use gstreamer; then
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of Cinnamon's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "org.cinnamon.recorder/pipeline to what you want to use."
+ fi
+ else
+ ewarn "Cinnamon's built-in screen recording utility is not installed"
+ ewarn "because gstreamer support is disabled."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}