summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-02-21 20:41:49 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-02-21 20:42:16 +0100
commit27ab6aa2a58cc04aafca70e61a7f2b301caa358f (patch)
treed55c6cfccbb1ca073bd97d7c7e29351971f6de83 /gnome-extra/eiciel/eiciel-0.9.12.1.ebuild
parentsys-apps/file: Security version bump to 5.36 (bug #678476) (diff)
downloadgentoo-27ab6aa2a58cc04aafca70e61a7f2b301caa358f.tar.gz
gentoo-27ab6aa2a58cc04aafca70e61a7f2b301caa358f.tar.bz2
gentoo-27ab6aa2a58cc04aafca70e61a7f2b301caa358f.zip
gnome-extra/eiciel: bump to 0.9.12.1
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'gnome-extra/eiciel/eiciel-0.9.12.1.ebuild')
-rw-r--r--gnome-extra/eiciel/eiciel-0.9.12.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnome-extra/eiciel/eiciel-0.9.12.1.ebuild b/gnome-extra/eiciel/eiciel-0.9.12.1.ebuild
new file mode 100644
index 000000000000..88a5e838f142
--- /dev/null
+++ b/gnome-extra/eiciel/eiciel-0.9.12.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
+HOMEPAGE="http://rofi.roger-ferrer.org/eiciel/"
+SRC_URI="http://rofi.roger-ferrer.org/eiciel/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xattr"
+
+RDEPEND="
+ >=sys-apps/acl-2.2.32
+ >=dev-cpp/gtkmm-3:3.0
+ >=gnome-base/nautilus-3
+ gnome-base/gvfs
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.1
+"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-version=3 \
+ $(use_enable xattr user-attributes)
+}