summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 22:50:09 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 23:53:05 -0500
commit191f8d92e0787393d80916f4f5713c0d1f83073f (patch)
tree257ebc9ecf77efdc4e17462bdef02b22aed20359 /gnome-extra/gnome-calendar
parentgnome-extra/gnome-characters: Version bump to 41.0 (diff)
downloadgentoo-191f8d92e0787393d80916f4f5713c0d1f83073f.tar.gz
gentoo-191f8d92e0787393d80916f4f5713c0d1f83073f.tar.bz2
gentoo-191f8d92e0787393d80916f4f5713c0d1f83073f.zip
gnome-extra/gnome-calendar: Version bump to 41.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-calendar')
-rw-r--r--gnome-extra/gnome-calendar/Manifest1
-rw-r--r--gnome-extra/gnome-calendar/gnome-calendar-41.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calendar/Manifest b/gnome-extra/gnome-calendar/Manifest
index 8e058eeaeca3..e53d8c023f40 100644
--- a/gnome-extra/gnome-calendar/Manifest
+++ b/gnome-extra/gnome-calendar/Manifest
@@ -1,3 +1,4 @@
DIST gnome-calendar-40.2.tar.xz 553344 BLAKE2B a144d94d16502ce6d864b66405f07f8115ef9705859d4e54025dfabcb8e99add6d1b25ba84152850378a79db858c4c7eb35b30c8e9ce80cac9384fb4876b0676 SHA512 1697eedfebd72fbd946024998246f7636c724550583ddc04d1c333b0824d38b2a806db0838a9ea5f39b64802c83fcb97cac792aeb4dc344e955e9c811dabd9b7
DIST gnome-calendar-41.0.tar.xz 576612 BLAKE2B b9544e9402edb25fae5b0598621116ac6c3215b2092675ef48b1b686cceebc43422a54b963ad6639b104833e6c07b58e57d86c5c514b7c025da0374d915a13ac SHA512 ba57af23f967a0900fd64399d9358c2dd131be86120e01d68cd4eee436e8a0bac6f4a3b154ffcfbb2d307ae632cfed7de29f79f843e4692cc1a81a82dadc5e4a
DIST gnome-calendar-41.1.tar.xz 582736 BLAKE2B bccb63eeb4092d5e451cb5e20858ef63c0b79bd381dc0b2982882b716e216e6195fed3cfe418ba191996c21db9048d7cf5d0b29ee92787a3e92558a4f052cd82 SHA512 c17ea429acbaf377036310bb42856f66632f712397a8e38279e7c537d6b4545a48935ada33d4169fd687022ad39ec73a2022b3e2f66c38325e60d45dfe41fcc6
+DIST gnome-calendar-41.2.tar.xz 583584 BLAKE2B ef21836ef87ba19de0c25f5cb73631b73a60352ca97db88dabbc1632097d3ef7e12c257fe946f7d92466f232248e1b27891394b44d73d61a3336521b2bb5d883 SHA512 1540a1e24d54bb157fadabe4201a97f2cae2c9487e267fff98273aa0dfc3715c4f734ba1e459c3c296c470337547a2b303309911ee7762e17738b292c18cc1bb
diff --git a/gnome-extra/gnome-calendar/gnome-calendar-41.2.ebuild b/gnome-extra/gnome-calendar/gnome-calendar-41.2.ebuild
new file mode 100644
index 000000000000..ac5e1d4c4c46
--- /dev/null
+++ b/gnome-extra/gnome-calendar/gnome-calendar-41.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Manage your online calendars with simple and modern interface"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calendar"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+# >=libical-1.0.1 for https://bugzilla.gnome.org/show_bug.cgi?id=751244
+DEPEND="
+ >=dev-libs/libical-1.0.1:0=
+ >=gnome-base/gsettings-desktop-schemas-3.21.2
+ >=gnome-extra/evolution-data-server-3.33.2:=[gtk]
+ net-libs/libsoup:2.4
+ >=dev-libs/libdazzle-3.33.1
+ >=gui-libs/libhandy-1.0.0:1=
+ >=dev-libs/glib-2.67.5:2
+ >=x11-libs/gtk+-3.22.0:3
+ >=net-libs/gnome-online-accounts-3.2.0:=
+ >=dev-libs/libgweather-40.0:=
+ >=app-misc/geoclue-2.4:2.0
+ >=sci-geosciences/geocode-glib-3.23
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}