summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-12 00:37:23 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-12 01:21:53 +0200
commit3c99fb0fb83e014f9d9f94b182dc1c886c84765f (patch)
treec7f0d089089c821ae52f981a6339b36f0829f511 /gnome-extra/gnome-characters/gnome-characters-3.24.0.ebuild
parentgnome-extra/gnome-calendar: remove old revision (diff)
downloadgentoo-3c99fb0fb83e014f9d9f94b182dc1c886c84765f.tar.gz
gentoo-3c99fb0fb83e014f9d9f94b182dc1c886c84765f.tar.bz2
gentoo-3c99fb0fb83e014f9d9f94b182dc1c886c84765f.zip
gnome-extra/gnome-characters: version bump 3.22.0 → 3.24.0
Small improvements and translations updates. Switch PYTHON_COMPAT to python3 as generator scripts have explicity references to it. Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'gnome-extra/gnome-characters/gnome-characters-3.24.0.ebuild')
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-3.24.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/gnome-characters-3.24.0.ebuild b/gnome-extra/gnome-characters/gnome-characters-3.24.0.ebuild
new file mode 100644
index 000000000000..d6daef0506eb
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-3.24.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/gjs-1.43.3
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=dev-libs/libunistring-0.9.5
+ >=x11-libs/gtk+-3.20:3[introspection]
+ >=x11-libs/pango-1.36[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
+"
+
+python_check_deps() {
+ use test && has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ sed 's/print \(.*\)/print(\1)/' -i "${S}"/tests/smoke_test.py || die
+
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable test dogtail)
+}
+
+src_test() {
+ virtx emake check
+}