summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-11-19 23:44:51 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-11-20 00:06:08 +0100
commit2819042a6acf511fb9c94a60f5649cd8b6d4bcec (patch)
tree519839b15939f9b9bc8f85a15a0ea313c0716f9a /gnome-extra/gnome-characters/gnome-characters-3.30.0.ebuild
parentmedia-sound/ario: Rename audioscrobbler -> scrobbler (diff)
downloadgentoo-2819042a6acf511fb9c94a60f5649cd8b6d4bcec.tar.gz
gentoo-2819042a6acf511fb9c94a60f5649cd8b6d4bcec.tar.bz2
gentoo-2819042a6acf511fb9c94a60f5649cd8b6d4bcec.zip
gnome-extra/gnome-characters: 3.26.2 → 3.30.0
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-characters/gnome-characters-3.30.0.ebuild')
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-3.30.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/gnome-characters-3.30.0.ebuild b/gnome-extra/gnome-characters/gnome-characters-3.30.0.ebuild
new file mode 100644
index 000000000000..5febaa80b536
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-3.30.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/gjs-1.43.3
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=dev-libs/libunistring-0.9.5
+ >=x11-libs/gtk+-3.20:3[introspection]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.36[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}