summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-19 17:01:12 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-19 19:38:19 -0400
commitf1d95cbea6d8646cfc04bb9c0227279e80c2f3bb (patch)
tree0c6735107da6735747953de250114a9bca491291 /gnome-extra/gnome-characters/gnome-characters-44.0.ebuild
parentmedia-gfx/simple-scan: Version bump to 44.0 (diff)
downloadgentoo-f1d95cbea6d8646cfc04bb9c0227279e80c2f3bb.tar.gz
gentoo-f1d95cbea6d8646cfc04bb9c0227279e80c2f3bb.tar.bz2
gentoo-f1d95cbea6d8646cfc04bb9c0227279e80c2f3bb.zip
gnome-extra/gnome-characters: Version bump to 44.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30243 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-characters/gnome-characters-44.0.ebuild')
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-44.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/gnome-characters-44.0.ebuild b/gnome-extra/gnome-characters/gnome-characters-44.0.ebuild
new file mode 100644
index 000000000000..9502a589d2b6
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-44.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/gjs-1.50
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=gui-libs/gtk-4.6:4[introspection]
+ >=gui-libs/libadwaita-1.2:1=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.36[introspection]
+ gnome-base/gnome-desktop:3[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}