summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-25 13:39:29 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-02 22:10:30 -0700
commit5abd86fd1e09fd3d6cfc6b834401730b28e01210 (patch)
treedba1978451a7d610d793cd18def7906715ff1e09 /gnome-extra/gnome-clocks/gnome-clocks-42.0.ebuild
parentdev-lang/vala: Drop old versions (diff)
downloadgentoo-5abd86fd1e09fd3d6cfc6b834401730b28e01210.tar.gz
gentoo-5abd86fd1e09fd3d6cfc6b834401730b28e01210.tar.bz2
gentoo-5abd86fd1e09fd3d6cfc6b834401730b28e01210.zip
gnome-extra/gnome-clocks: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-clocks/gnome-clocks-42.0.ebuild')
-rw-r--r--gnome-extra/gnome-clocks/gnome-clocks-42.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnome-extra/gnome-clocks/gnome-clocks-42.0.ebuild b/gnome-extra/gnome-clocks/gnome-clocks-42.0.ebuild
new file mode 100644
index 000000000000..2433248fc543
--- /dev/null
+++ b/gnome-extra/gnome-clocks/gnome-clocks-42.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+VALA_MIN_API_VERSION="0.56"
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clocks application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Clocks"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.68:2
+ >=gui-libs/gtk-4.5:4
+ >=media-libs/gsound-0.98
+ >=dev-libs/libgweather-4.0.0:4=
+ gnome-base/gnome-desktop:4
+ >=sci-geosciences/geocode-glib-1
+ >=app-misc/geoclue-2.4:2.0
+ >=gui-libs/libadwaita-1.0:1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ dev-libs/libgweather:4[vala]
+ media-libs/gsound[vala]
+ gui-libs/libadwaita:1[vala]
+"
+
+DOCS=( AUTHORS.md CONTRIBUTING.md README.md )
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofile=default
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}