summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-10-09 14:10:43 +0300
committerMart Raudsepp <leio@gentoo.org>2021-10-09 14:22:59 +0300
commit981d396535559ecaa218933d45fad58a2f1002fb (patch)
tree45792b3e35ac2fa08eed3ff3c924535a29e0377e /gnome-extra/gnome-contacts
parentgnome-extra/gnome-calendar: bump to 41.0 (diff)
downloadgentoo-981d396535559ecaa218933d45fad58a2f1002fb.tar.gz
gentoo-981d396535559ecaa218933d45fad58a2f1002fb.tar.bz2
gentoo-981d396535559ecaa218933d45fad58a2f1002fb.zip
gnome-extra/gnome-contacts: bump to 41.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-contacts')
-rw-r--r--gnome-extra/gnome-contacts/Manifest1
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-41.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/gnome-extra/gnome-contacts/Manifest b/gnome-extra/gnome-contacts/Manifest
index 86e636ebca2a..016f9fc6e45e 100644
--- a/gnome-extra/gnome-contacts/Manifest
+++ b/gnome-extra/gnome-contacts/Manifest
@@ -1 +1,2 @@
DIST gnome-contacts-40.0.tar.xz 270412 BLAKE2B 4d7970ac5417dfbd9b0acf51efd8ce1310cee51f90de8d8afa0239d918269642869e35befb64cbfb5acf1bde17ac738192d5ef802d27df47936165b03ed20b51 SHA512 5f9bb7e805cc67a379fd1ab5945774f5067be64d6577bc9cf0514c4ca6b53937555dc96591244d8be418b2b07f7c5401e8186dca5baff3a2b6c5a2ae459a676f
+DIST gnome-contacts-41.0.tar.xz 275248 BLAKE2B c0611a131ce1ebb74b96e96e2e1b9370526b56c49ee43876273fdf5b2f3b333ad2aad85c50ddcebaac85ee8c996037fec3209c6765cab7b37b49ced04a82a7a8 SHA512 310f333c0863d8e58c2280b994071b2655eee7224ab80a468ffc7acc61834d3f6dbb794bbdc5b8d4428226bab96f3ea65b8bed39df79d88704e38b51a8f4b05f
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-41.0.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-41.0.ebuild
new file mode 100644
index 000000000000..7cf6f2b6d3a1
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-41.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="telepathy v4l"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-1.54
+ dev-libs/folks[vala(+)]
+ net-libs/gnome-online-accounts[vala]
+ gnome-extra/evolution-data-server[gtk,vala]
+ telepathy? ( net-libs/telepathy-glib[vala] )
+ >=gui-libs/libhandy-1.1.0:1[vala]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=gnome-extra/evolution-data-server-3.30:=[gnome-online-accounts]
+ >=dev-libs/folks-0.11.4:=[eds,telepathy?]
+ >=dev-libs/glib-2.58:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-base/gnome-desktop-3.0:3=
+ net-libs/gnome-online-accounts:=
+ >=x11-libs/gtk+-3.23.1:3
+ v4l? ( >=media-video/cheese-3.5.91:= )
+ telepathy? ( >=net-libs/telepathy-glib-0.22 )
+ >=gui-libs/libhandy-1.0.0:1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ ${VALA_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature v4l cheese)
+ $(meson_use telepathy)
+ -Dmanpage=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}