summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-20 15:17:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-20 15:17:57 -0500
commit2f8d66d7600d62428c4b0e762c4732590607b2ef (patch)
tree9f575d4a86692a853b3b727d985d7092b06b5319 /gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild
parentx11-misc/redshift: Fix for USE=-gtk (diff)
downloadgentoo-2f8d66d7600d62428c4b0e762c4732590607b2ef.tar.gz
gentoo-2f8d66d7600d62428c4b0e762c4732590607b2ef.tar.bz2
gentoo-2f8d66d7600d62428c4b0e762c4732590607b2ef.zip
gnome-extra/gnome-integration-spotify: fix dbus integration
Closes: https://bugs.gentoo.org/782433 Package-Manager: Portage-3.0.17, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild')
-rw-r--r--gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild
new file mode 100644
index 000000000000..049a2479a33b
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit gnome2-utils python-r1
+
+DESCRIPTION="GNOME integration for Spotify"
+HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
+#SRC_URI="https://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+SRC_URI="https://github.com/mrpdaemon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ x11-misc/wmctrl
+ x11-misc/xautomation
+ x11-misc/xdotool
+ x11-apps/xwininfo"
+
+PATCHES=(
+ "${FILESDIR}/gnome-integration-spotify-command-line-parsing.patch"
+ "${FILESDIR}/gnome-integration-spotify-correct-interface.patch"
+ "${FILESDIR}/gnome-integration-spotify-use-glib.patch"
+)
+
+src_install() {
+ dobin spotify-dbus.py
+ python_replicate_script "${ED}"/usr/bin/spotify-dbus.py
+ mkdir -p "${D}/etc/gconf/schemas"
+ cp spotify.schemas "${D}/etc/gconf/schemas"
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_prerm() {
+ gnome2_gconf_uninstall
+}