summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-integration-spotify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-integration-spotify')
-rw-r--r--gnome-extra/gnome-integration-spotify/Manifest2
-rw-r--r--gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20131013.ebuild45
-rw-r--r--gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907.ebuild46
-rw-r--r--gnome-extra/gnome-integration-spotify/metadata.xml13
4 files changed, 106 insertions, 0 deletions
diff --git a/gnome-extra/gnome-integration-spotify/Manifest b/gnome-extra/gnome-integration-spotify/Manifest
new file mode 100644
index 000000000000..dc5157f48654
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-integration-spotify-20140907.tar.gz 6709 SHA256 f1906851329461d3e1a2a7171fd8c6be5082505b04415f2879b1f634b554bbfe SHA512 51e0e7fdb0912e230b0965ca05740b01633b3bc0219dd6e8c31ad5a9378b15c1b44ce1f99098900af7a478f0d6180c3ee015c1717603b6c2fb4c54769dddb874 WHIRLPOOL 4f0867fd2aa0d62d9e71c933541896092991ee4389a79845c2ceff2c2712935405134291024817e9039afa0b62da9538cc329e110b739db28e40c1df2a28070e
+DIST gnome-integration-spotify-git-20131013.tgz 6703 SHA256 bb55df923ddf4024f041ccb64753e394083e0c2eac7265f2c875e3432f99f5c8 SHA512 de4033c8bb955732eeb573a9328d068716584b85f4fa62d8090ea9f35c43a032389dd7cbf3d4f3380bb2e46ebc37737c8cf93d67b4f381939742001762da267c WHIRLPOOL 0c5684350fff53b5cb3aa67593c0d12fec69904bca6b55cd70d95a933589be4486e158f4d2cb04e294321ca10c05f2bc062cba0aa3503e6198048743b6d5ec47
diff --git a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20131013.ebuild b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20131013.ebuild
new file mode 100644
index 000000000000..ced929fb8b8f
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20131013.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit gnome2-utils
+
+DESCRIPTION="GNOME integration for Spotify"
+HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
+SRC_URI="http://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/python
+ dev-python/dbus-python
+ media-gfx/imagemagick
+ x11-misc/wmctrl
+ x11-misc/xautomation
+ x11-misc/xdotool
+ x11-apps/xwininfo"
+
+src_install() {
+ dobin spotify-dbus.py
+ mkdir -p "${D}/etc/gconf/schemas"
+ cp spotify.schemas "${D}/etc/gconf/schemas"
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_prerm() {
+ gnome2_gconf_uninstall
+}
diff --git a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907.ebuild b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907.ebuild
new file mode 100644
index 000000000000..ebe21c3dd441
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit gnome2-utils
+
+DESCRIPTION="GNOME integration for Spotify"
+HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
+#SRC_URI="http://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+SRC_URI="https://github.com/mrpdaemon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/python
+ dev-python/dbus-python
+ media-gfx/imagemagick
+ x11-misc/wmctrl
+ x11-misc/xautomation
+ x11-misc/xdotool
+ x11-apps/xwininfo"
+
+src_install() {
+ dobin spotify-dbus.py
+ mkdir -p "${D}/etc/gconf/schemas"
+ cp spotify.schemas "${D}/etc/gconf/schemas"
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_prerm() {
+ gnome2_gconf_uninstall
+}
diff --git a/gnome-extra/gnome-integration-spotify/metadata.xml b/gnome-extra/gnome-integration-spotify/metadata.xml
new file mode 100644
index 000000000000..ff4612c9061c
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">mrpdaemon/gnome-integration-spotify</remote-id>
+ </upstream>
+</pkgmetadata>