summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-10 12:57:36 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-11 14:07:05 +0100
commitba7b0d77f5ecf1b671b8904d9cfa6473c5157743 (patch)
tree25d3d88a84fae31d600414fc2efb510aee12d330 /gnome-extra/gnome-packagekit/gnome-packagekit-3.30.0.ebuild
parentdev-python/jaraco-packaging: bump to 5.2 (diff)
downloadgentoo-ba7b0d77f5ecf1b671b8904d9cfa6473c5157743.tar.gz
gentoo-ba7b0d77f5ecf1b671b8904d9cfa6473c5157743.tar.bz2
gentoo-ba7b0d77f5ecf1b671b8904d9cfa6473c5157743.zip
gnome-extra/gnome-packagekit: 3.24.0 → 3.30.0
Switched to meson build system. Just translation updates since 3.24. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-packagekit/gnome-packagekit-3.30.0.ebuild')
-rw-r--r--gnome-extra/gnome-packagekit/gnome-packagekit-3.30.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/gnome-packagekit/gnome-packagekit-3.30.0.ebuild b/gnome-extra/gnome-packagekit/gnome-packagekit-3.30.0.ebuild
new file mode 100644
index 000000000000..078f468963e7
--- /dev/null
+++ b/gnome-extra/gnome-packagekit/gnome-packagekit-3.30.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="PackageKit client for the GNOME desktop"
+HOMEPAGE="https://www.freedesktop.org/software/PackageKit/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd test"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.15.3:3
+ >=app-admin/packagekit-base-0.9.1
+ systemd? (
+ sys-auth/polkit
+ >=sys-apps/systemd-42 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-sgml-utils
+ app-text/docbook-sgml-dtd:4.1
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+# NOTES:
+# app-text/docbook-sgml-utils and dtd required for man pages
+
+# UPSTREAM:
+# see if tests can forget about display (use eclass for that ?)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ GSETTINGS_SCHEMA_DIR="${S}/data" virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}