summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-10-03 21:00:32 +0200
committerPacho Ramos <pacho@gentoo.org>2021-10-03 21:00:51 +0200
commit624ec809adea7f35f242ef3d67ea6ddd6eaa32fc (patch)
tree4c6112097aa5bd08c1f1b825927de73a938a55b6 /gnome-extra/gnome-shell-extension-appindicator
parentdev-python/pluggy: Stabilize 1.0.0 ppc, #815970 (diff)
downloadgentoo-624ec809adea7f35f242ef3d67ea6ddd6eaa32fc.tar.gz
gentoo-624ec809adea7f35f242ef3d67ea6ddd6eaa32fc.tar.bz2
gentoo-624ec809adea7f35f242ef3d67ea6ddd6eaa32fc.zip
gnome-extra/gnome-shell-extension-appindicator: Bump to 41
Closes: https://bugs.gentoo.org/791214 Package-Manager: Portage-3.0.24, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-appindicator')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-41.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/Manifest b/gnome-extra/gnome-shell-extension-appindicator/Manifest
index 5a09d1fb070d..692c8fe2e8a3 100644
--- a/gnome-extra/gnome-shell-extension-appindicator/Manifest
+++ b/gnome-extra/gnome-shell-extension-appindicator/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-appindicator-40.tar.gz 48681 BLAKE2B cec52930bcb163a6761662deb3bd52202abadfc90fdd12877c711e4f4cf5038b9e7f3822259ced5ba39a632d2a1e0a83ffc4dc563ba184742dd1de2941acfe73 SHA512 72b3ecf0eadde40fd3567b19d7c7064953847ec86298691097f9fe14cada37206f8edd898c1d2a8fe71aeb0ace4921d1797d2dcc9eeacc0cb04a25841125b2ef
+DIST gnome-shell-extension-appindicator-41.tar.gz 52835 BLAKE2B 0d0bdc73bc10057ea012d26bd640c7ecd8005a7b36e7316b7d616e28a429e43f3b36ab2615ac4d6227dd5176b3a4f629a70c960e8f8961063c6979d5b04e5005 SHA512 8c67011884bc4cf6e4ddfc3ac0c191830775050d07cf3f8d7462ff4e0050cea00fd3f8372b1c75211e433344c64fea9903982769bc4d0428b51161efd275f5d9
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-41.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-41.ebuild
new file mode 100644
index 000000000000..8486bade2681
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-41.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils meson
+
+DESCRIPTION="Support Ubuntu AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ dev-libs/libappindicator:3
+ >=gnome-base/gnome-shell-3.34
+"
+DEPEND=""
+BDEPEND=""
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}