summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-03-25 11:18:54 +0200
committerMart Raudsepp <leio@gentoo.org>2017-03-25 11:20:44 +0200
commit0aeba9e7ae3454d768b748d00e3ed0e1000b3c80 (patch)
tree28c707f3882a6eedff8946aa1c17de497efc2f6b /gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild
parentdev-python/pycryptodome: re-add Prefix keywords, bug #613760 (diff)
downloadgentoo-0aeba9e7ae3454d768b748d00e3ed0e1000b3c80.tar.gz
gentoo-0aeba9e7ae3454d768b748d00e3ed0e1000b3c80.tar.bz2
gentoo-0aeba9e7ae3454d768b748d00e3ed0e1000b3c80.zip
gnome-extra/gnome-shell-extensions-topicons-plus: add package as gnome-shell-extensions-topicons replacement
Package-Manager: Portage-2.3.4, Repoman-2.3.1
Diffstat (limited to 'gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild
new file mode 100644
index 000000000000..ad6dd12e0b8a
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Moves legacy tray icons to top panel"
+HOMEPAGE="https://extensions.gnome.org/extension/1031/topicons/"
+SRC_URI="https://github.com/phocean/TopIcons-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.16
+"
+DEPEND="${COMMON_DEPEND}"
+
+#src_compile() {
+ # It redoes this with "make install" later due to a dumb Makefile, so don't bother
+ #make build
+#}
+
+src_install() {
+ # TODO: Figure out if we can get the schemas to standard location, in a way that works properly runtime too
+ make install INSTALL_PATH="${ED}usr/share/gnome-shell/extensions/"
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/README.md" || die
+ dodoc README.md
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}