summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-30 14:08:57 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-30 14:22:22 -0400
commitf48d071cbe40304d1a9a1f7e90a2400854abafbe (patch)
treed376125a8f32d78e716ddcdfad8c1af9d9adab62 /gnome-extra/gnome-software
parentdev-util/umockdev: Version bump to 0.17.13 (diff)
downloadgentoo-f48d071cbe40304d1a9a1f7e90a2400854abafbe.tar.gz
gentoo-f48d071cbe40304d1a9a1f7e90a2400854abafbe.tar.bz2
gentoo-f48d071cbe40304d1a9a1f7e90a2400854abafbe.zip
gnome-extra/gnome-software: Version bump to 42.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-software')
-rw-r--r--gnome-extra/gnome-software/Manifest1
-rw-r--r--gnome-extra/gnome-software/gnome-software-42.2.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/gnome-extra/gnome-software/Manifest b/gnome-extra/gnome-software/Manifest
index 6b4383ccd5d2..159e4ae6b25f 100644
--- a/gnome-extra/gnome-software/Manifest
+++ b/gnome-extra/gnome-software/Manifest
@@ -1,3 +1,4 @@
DIST gnome-software-41.4.tar.xz 3243380 BLAKE2B a8511c776d902639a01b1194e7dd23f22e98c6fa5fd0624cf9d7b7ae96f0ca313eb139a396e4bf8c7b2ec94db66a3f6ef89a8d77cbd1820291f01cd6c70ec2db SHA512 97c51fd21bd5fd2f7d11e00811747992ff0e404380f84cda07e5c7cae3962034c9169ebad95f875056233c9b1d44347a0c15c61e0f018bb3128e7c7d5d3c74b2
DIST gnome-software-42.0.tar.xz 2266316 BLAKE2B c672ecd32d80168aca9b651beb1f58562fb2874656f3c400c9301a0ed87e19cdd74554ef5995daec7f435cf689ad9dc3404623cab4dbb1e00602aa8b191ed996 SHA512 f630232d164d1a7adcf9a91133769c6fe4ce62cdaeccd49b991330682eeccfddc8f83c7326802aaabdb4fc537243c0fd19741c702f4d23d75ebd71e9abb3da92
DIST gnome-software-42.1.tar.xz 2266468 BLAKE2B 9dfe336184e2a1ffc244ef37d31b006831e18e399e6393013842d25492062d2093210117182f6fc7521892f25864056244200c7f9a88f65da86e99373bc40daa SHA512 292a17e94c7409198fdff4250a88cb240a126c3d77a9cfee1ea8608fdc482d75af6f8fc91c5c6c068b474edea6dcb197f88ec09081a8b270d5f3eda67db755ad
+DIST gnome-software-42.2.tar.xz 2274824 BLAKE2B 0c971bbe8f7e074ddc23923f14aeca4e95a0c305d016548d69bc51100859dfc30fcfcfbfe88189b6a0e4d2531c8223822aa8f16bee5bba6046266077e7c26eda SHA512 2b231afbedb241b8957fa902c37cd85734cdb8b2071cd32ac75ae2e9e064483fe1e9e8d49f2e6df478fdd01e9c6225a85887ba2af1792a9150b89cea75ef8bb4
diff --git a/gnome-extra/gnome-software/gnome-software-42.2.ebuild b/gnome-extra/gnome-software/gnome-software-42.2.ebuild
new file mode 100644
index 000000000000..8ef94587b026
--- /dev/null
+++ b/gnome-extra/gnome-software/gnome-software-42.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Gnome install & update software"
+HOMEPAGE="https://wiki.gnome.org/Apps/Software"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flatpak +firmware gnome gtk-doc sysprof udev"
+RESTRICT="test" # See TODO below
+
+RDEPEND="
+ >=dev-libs/appstream-0.14.0:0=
+ >=x11-libs/gdk-pixbuf-2.32.0:2
+ >=dev-libs/libxmlb-0.1.7:=
+ >=gui-libs/gtk-4.6:4
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/json-glib-1.6.0
+ >=net-libs/libsoup-2.52.0:2.4
+ >=gui-libs/libadwaita-1.0.1:1
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ gnome? ( >=gnome-base/gsettings-desktop-schemas-3.18.0 )
+ sys-auth/polkit
+ firmware? ( >=sys-apps/fwupd-1.5.6 )
+ flatpak? (
+ >=sys-apps/flatpak-1.9.1
+ dev-util/ostree
+ )
+ udev? ( dev-libs/libgudev )
+ >=gnome-base/gsettings-desktop-schemas-3.11.5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+"
+# test? ( dev-util/valgrind )
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ sed -i -e '/install_data.*README\.md.*share\/doc\/gnome-software/d' meson.build || die
+ # We don't need language packs download support, and it fails tests in 3.34.2 for us (if they are enabled)
+ sed -i -e '/subdir.*fedora-langpacks/d' plugins/meson.build || die
+ # Trouble talking to spawned gnome-keyring socket for some reason, even if wrapped in dbus-run-session
+ # TODO: Investigate; seems to work outside ebuild .. test/emerge
+ sed -i -e '/g_test_add_func.*gs_auth_secret_func/d' lib/gs-self-test.c || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_feature gnome gsettings_desktop_schemas) # Honoring of GNOME date format settings.
+ -Dman=true
+ -Dpackagekit=false
+ # -Dpackagekit_autoremove
+ -Dpolkit=true
+ -Deos_updater=false # Endless OS updater
+ $(meson_use firmware fwupd)
+ $(meson_use flatpak)
+ -Dmalcontent=false
+ -Drpm_ostree=false
+ $(meson_use udev gudev)
+ -Dapt=false
+ -Dsnap=false
+ -Dexternal_appstream=false
+ -Dvalgrind=false
+ $(meson_use gtk-doc gtk_doc)
+ -Dhardcoded_popular=true
+ -Ddefault_featured_apps=false # TODO: Will this be beneficial to us with flatpak at least? If enabled, it shows some apps under installed (probably merely due to /usr/share/app-info presence), but launching and removal of them is broken
+ -Dmogwai=false #TODO?
+ $(meson_feature sysprof)
+ -Dprofile=''
+ -Dsoup2=true
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}