summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-16 17:27:07 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-16 17:33:08 -0400
commit58ca3ec90fbc923e282c9be2d7c43a58bd417428 (patch)
treeeebb2f451649ded6a2deff73efea34a7ede62a56 /gnome-extra/gnome-system-monitor
parentapp-emulation/winetricks: Sync with ::wine (diff)
downloadgentoo-58ca3ec90fbc923e282c9be2d7c43a58bd417428.tar.gz
gentoo-58ca3ec90fbc923e282c9be2d7c43a58bd417428.tar.bz2
gentoo-58ca3ec90fbc923e282c9be2d7c43a58bd417428.zip
gnome-extra/gnome-system-monitor: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-system-monitor')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-40.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index 32f0f85ed6a8..3ba1a1d6d825 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1 +1,2 @@
DIST gnome-system-monitor-3.38.0.tar.xz 712320 BLAKE2B a59fbe39a8c04793c5584f645dbe0e0bcb9747394c0b923532afc95443aadeeb17ca211248a5c61747699eb95d4f8530fcc18076753bcc6d28cf2ce47a4f6825 SHA512 9f54045fa837b85d40a80bc8b519f91513ae27ca157e07f415860e906444bf144b7a7a66e4a2a9a5b1fea4e69305414cf081bb34624c91d1476265b37b59368c
+DIST gnome-system-monitor-40.0.tar.xz 763344 BLAKE2B 3a9b0f7a823eda4a00b58ece53604a127047a0d087fdc74584d5e1453744063332bb084ab32dc624812d80fa233a0fbbb39c20e2cc18b962dbd248799d587a3a SHA512 b0e326c3abdca0a3b5807976a04b7090861717840b11829d75fe5da91ef7adb34b80d2952aee4c1ff843bd5356dab7490d1c2e403712fd3c1381baddb8542501
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-40.0.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-40.0.ebuild
new file mode 100644
index 000000000000..2a765ffce9bf
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-40.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/atkmm-2.28:0
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gui-libs/libhandy-1.0.0:1=
+ >=gnome-base/librsvg-2.35:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}