summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-13 22:24:57 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-13 22:27:34 -0800
commit92547f8e7547960daccf510a79030beeb517fbb4 (patch)
treee8a5b57fc582b3a2bfe0d4330960567a12bef922 /gnome-extra/gnome-user-docs
parentdev-lang/lua: 5.4.4 bump (diff)
downloadgentoo-92547f8e7547960daccf510a79030beeb517fbb4.tar.gz
gentoo-92547f8e7547960daccf510a79030beeb517fbb4.tar.bz2
gentoo-92547f8e7547960daccf510a79030beeb517fbb4.zip
gnome-extra/gnome-user-docs: Version bump to 41.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-user-docs')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-41.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index 1b3cea348862..21b23c193f5d 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1,2 +1,3 @@
DIST gnome-user-docs-40.5.tar.xz 9210512 BLAKE2B 0fe638636377d1c392d208c55016cdc346fa1ec64d327ab9ded9b58744d115c74d5a03927836138cb2d58c9df735d8bc032da4a7ff3ef3ffa53a1a59b88a3006 SHA512 dbef51c262862b211304158fd9aa7bf75ab20bbf21ed0bebe0a1c547cb53e580d32062a6f362f0750a8fbe1e93e8987593c80fa7fbb758c1a61827256db69d52
DIST gnome-user-docs-41.1.tar.xz 9402668 BLAKE2B 952f2c117df9a9e35ae9fab13e5da402f804bce8d4fc96c07355d99e10debeb7b214f72b976826d016ae9f8d8c8a1b558d9a06f8f20e37ddd56404b6a794925a SHA512 49e08947b87ff551cfcf7de9e791de664d32f5628e1e7b4dbcf4b03e38d3e09edda602239dc52bef22a3711c437b669f8a092a33a385531e15311a0c858e78b1
+DIST gnome-user-docs-41.2.tar.xz 9407232 BLAKE2B 81c6d638e6cf3011cf4f2ee835c293fd0152435d2f4d07e7bc403882e378d140d7e03fbaca7f87e23f6c65d104dc7be4a2bc0902a3e1a5ab42815ceb250ff4b0 SHA512 982fa4c491a530df0067c3f437c961f84c393f1f95895e86f348609fa0407ffa6a33dbc961c87c5083180d4ad1a069ec2886d0ec841e9c965f21cb0b55322f4b
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-41.2.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-41.2.ebuild
new file mode 100644
index 000000000000..c483a2640eaf
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-41.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}