summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-07-12 12:13:11 -0700
committerMatt Turner <mattst88@gentoo.org>2021-07-12 12:13:40 -0700
commit985903fa021cda0963a2cdac7666983ef28fa22a (patch)
tree4d8aed0d5a8667247663f55580ff2499a20f74c8 /gnome-extra/gnome-user-docs
parentx11-terms/gnome-terminal: Version bump to 3.40.3 (diff)
downloadgentoo-985903fa021cda0963a2cdac7666983ef28fa22a.tar.gz
gentoo-985903fa021cda0963a2cdac7666983ef28fa22a.tar.bz2
gentoo-985903fa021cda0963a2cdac7666983ef28fa22a.zip
gnome-extra/gnome-user-docs: Version bump to 40.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-user-docs')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-40.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index c86e8e9da40a..350da1134fdf 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1 +1,2 @@
DIST gnome-user-docs-40.1.tar.xz 9264892 BLAKE2B 3c27662d516839d411444b811d2c60da51b055a7200958ee50908092bd135e182c2b359f47b711b276a6a9b6b029b767b23bd88fecc32f2c80fa2652ace40184 SHA512 a5ebd9bfbdf13c6922db2035c740f729dc89a2dfa991e74cb835d1c8e28ec4d0d08aaf7388d00d6df83f53a6261bebc1ea32e5b57287c13b2237221a56a34332
+DIST gnome-user-docs-40.3.tar.xz 9141728 BLAKE2B 9634dfa526d7e781400563e0800f25fc8aa520d97fe0e02f3a06a1f82bb0019ff28e9bf0c8a2698c7d081d7b54a1d53be4475db6615d40c3407b632252cc8aae SHA512 e96f4535761c902999b210060f9bbf19384151752315abc7cf20f8b0ef1f599fe132f398db61318ea24eab8e3dc65812fc05a5ed549e4cedabaf809af39f515b
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-40.3.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-40.3.ebuild
new file mode 100644
index 000000000000..aef106ecb64f
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-40.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}