summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-17 20:14:05 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-17 20:14:05 +0100
commitbc5f14a43d8afee8c95aa48c2ada939478a40289 (patch)
tree6b55e596b158792516353821cf0f4a661c41b744 /gnome-extra/gnome-user-share/gnome-user-share-3.18.0.ebuild
parentgnome-extra/cinnamon-translations: Drop old (diff)
downloadgentoo-bc5f14a43d8afee8c95aa48c2ada939478a40289.tar.gz
gentoo-bc5f14a43d8afee8c95aa48c2ada939478a40289.tar.bz2
gentoo-bc5f14a43d8afee8c95aa48c2ada939478a40289.zip
gnome-extra/gnome-user-share: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'gnome-extra/gnome-user-share/gnome-user-share-3.18.0.ebuild')
-rw-r--r--gnome-extra/gnome-user-share/gnome-user-share-3.18.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-share/gnome-user-share-3.18.0.ebuild b/gnome-extra/gnome-user-share/gnome-user-share-3.18.0.ebuild
new file mode 100644
index 000000000000..530f69e65e35
--- /dev/null
+++ b/gnome-extra/gnome-user-share/gnome-user-share-3.18.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib
+
+DESCRIPTION="Personal file sharing for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-share"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# FIXME: could libnotify be made optional ?
+# FIXME: selinux automagic support
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/nautilus-2.91.7
+ media-libs/libcanberra[gtk3]
+ >=www-apache/mod_dnssd-0.6
+ >=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile,apache2_mpms_prefork]
+ >=x11-libs/libnotify-0.7:=
+"
+DEPEND="${RDEPEND}
+ !<gnome-base/gnome-control-center-3.9
+ app-text/yelp-tools
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --with-httpd=apache2 \
+ --with-modules-path=/usr/$(get_libdir)/apache2/modules/
+}