summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-18 19:50:40 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-18 20:01:39 -0700
commit9e1d7fb29c6eae42f7b892c9b8b67e16a149e817 (patch)
tree8189d96a7d47f24fab8c37d5ea15335723c7c163 /gnome-extra/gnome-weather
parentgnome-extra/gnome-shell-extensions: Version bump to 40.4 (diff)
downloadgentoo-9e1d7fb29c6eae42f7b892c9b8b67e16a149e817.tar.gz
gentoo-9e1d7fb29c6eae42f7b892c9b8b67e16a149e817.tar.bz2
gentoo-9e1d7fb29c6eae42f7b892c9b8b67e16a149e817.zip
gnome-extra/gnome-weather: Version bump to 40.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-40.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 239f542bcda1..f5c3285a164d 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1 +1,2 @@
DIST gnome-weather-40.0.tar.xz 938732 BLAKE2B bc46da61e9620278f5abc7964b869520da85837739923618b2ade114c8561fc6125e7dca2f2aef5715fec7dfa0561c693f75278d050900cb948f8d1ea42f58ba SHA512 c4560c1a1535a0c2889c8cd934926217a7caceb1b646fa4bb961c7cbde38b9b545a567f24fb81e47c61a2ac3e456a5432e8979591eb5a169fe5849bbd99d6333
+DIST gnome-weather-40.1.tar.xz 941636 BLAKE2B 110b972eb3eb6319632d00592f9bf50220bb6976bb27f814606758fd6ce98ad9dfdfabcb0e2d4a68f8005aa3cb92538e4820c8add8f7f8cb94a96f7df9453cf8 SHA512 47086225a2f0212665e53f053d46b54792d4daebff841bb751a7ed8ca7e2e1d60f0247d890011a03cab4104b0461b71316ff9b6eaea671c68bc1713c38e447dc
diff --git a/gnome-extra/gnome-weather/gnome-weather-40.1.ebuild b/gnome-extra/gnome-weather/gnome-weather-40.1.ebuild
new file mode 100644
index 000000000000..ddc78bc521b6
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-40.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/gjs-1.50
+ >=app-misc/geoclue-2.3.1:2.0
+ >=dev-libs/libgweather-40.0:=
+ >=gui-libs/libhandy-1.1.90:1=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}