summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r3.ebuild')
-rw-r--r--gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r3.ebuild b/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r3.ebuild
new file mode 100644
index 000000000000..55f3772e87d5
--- /dev/null
+++ b/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A GTK+ based configuration utility for the synaptics driver"
+HOMEPAGE="https://wiki.gnome.org/Attic/GPointingDeviceSettings"
+SRC_URI="mirror://sourceforge.jp/gsynaptics/45812/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# recent enough x11-base/xorg-server required
+RDEPEND="
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.14.0:2
+ >=gnome-base/gconf-2.24:2
+ >=gnome-base/gnome-settings-daemon-2.28
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libX11-1.2.0
+ !<=x11-base/xorg-server-1.6.0
+ !gnome-extra/gsynaptics
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35.5
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-crash.patch" \
+ "${FILESDIR}/${P}-plugin.patch" \
+ "${FILESDIR}/${P}-reboot.patch" \
+ "${FILESDIR}/${P}-gtk22.patch" \
+ "${FILESDIR}/${P}-gsd-crash.patch" \
+ "${FILESDIR}/${P}-gsd-3.2-fix.patch" \
+ "${FILESDIR}/${P}-fix-build.patch"
+
+ # Disable gsd plugin as it's incompatible since 3.8, bug #514672
+ sed -i -e 's/ gnome-settings-daemon-plugins//' modules/Makefile.am || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}