summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-01-06 18:39:29 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-01-07 15:31:01 +0200
commite2cf45c39407ad8daf58a116d54b8e1135481f1b (patch)
tree58caf3703c3fd497ff4f6ba41e632131446973a1 /gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild
parentdev-java/junit: add unzip to BDEPEND (diff)
downloadgentoo-e2cf45c39407ad8daf58a116d54b8e1135481f1b.tar.gz
gentoo-e2cf45c39407ad8daf58a116d54b8e1135481f1b.tar.bz2
gentoo-e2cf45c39407ad8daf58a116d54b8e1135481f1b.zip
gnome-extra/krb5-auth-dialog: add new package 43.0
An application to acquire and list Kerberos tickets. Closes: https://bugs.gentoo.org/323301 Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/28988 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild')
-rw-r--r--gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild b/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild
new file mode 100644
index 000000000000..8e64e763ad12
--- /dev/null
+++ b/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson
+
+DESCRIPTION="An application to acquire and list Kerberos tickets."
+HOMEPAGE="https://gitlab.gnome.org/GNOME/krb5-auth-dialog/"
+SRC_URI="https://download.gnome.org/sources/${PN}/$(ver_cut 1)/${P}.tar.xz"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-crypt/gcr:=
+ dev-libs/glib:2
+ sys-libs/pam
+ x11-libs/gtk+:3
+ || (
+ app-crypt/heimdal
+ app-crypt/mit-krb5
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/itstool"