summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:51 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:44:07 +0100
commitf159ad1d1a72e77e313549da27abd2ef43812a69 (patch)
tree0deab91a4e997daee4e991912551dc45990b954e /gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild
parentgames-emulation/vbam: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-f159ad1d1a72e77e313549da27abd2ef43812a69.tar.gz
gentoo-f159ad1d1a72e77e313549da27abd2ef43812a69.tar.bz2
gentoo-f159ad1d1a72e77e313549da27abd2ef43812a69.zip
gnome-extra/libgsf: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild')
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild b/gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild
new file mode 100644
index 000000000000..dd4b0c664e78
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}