summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 21:08:49 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 21:13:14 +0200
commit25cb933c8d5447be8d7859616aee80c019ada5c2 (patch)
tree627ba540c735435ae7831438da3efa1fa3bb1342 /gnome-extra/nemo
parentgnome-extra/nemo: Drop old (diff)
downloadgentoo-25cb933c8d5447be8d7859616aee80c019ada5c2.tar.gz
gentoo-25cb933c8d5447be8d7859616aee80c019ada5c2.tar.bz2
gentoo-25cb933c8d5447be8d7859616aee80c019ada5c2.zip
gnome-extra/nemo: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'gnome-extra/nemo')
-rw-r--r--gnome-extra/nemo/Manifest1
-rw-r--r--gnome-extra/nemo/nemo-3.0.6.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/gnome-extra/nemo/Manifest b/gnome-extra/nemo/Manifest
index 0fb41d5f2dde..279c187ecc97 100644
--- a/gnome-extra/nemo/Manifest
+++ b/gnome-extra/nemo/Manifest
@@ -1 +1,2 @@
DIST nemo-2.8.7.tar.gz 1413445 SHA256 79ca0e28b43ebb701a6449424be1be4224e9014bf1bb3b722d77b23ecb3afab9 SHA512 5daf57f30c3eb9bfaf6eab80e71f84763bad1ca707ecc96194ae9ce5899d33b4fb1e0f784c237741ba06d80b2c6247d3d0d1a6146fb954c5d6a6e18583322f7c WHIRLPOOL d65e1eda923b107a89dca3ebb60a68fe5c71ee9f9aeec3ba6e4d1c52266be91724ff1ead1354fe6998e92f06faaa2a1e4554e28cf59ac2e0dc1e6375b2be8e20
+DIST nemo-3.0.6.tar.gz 1363302 SHA256 3a2704e110a30625f9e807d21df44a577606d383c1eaf1ef4dae0e4dd321cdec SHA512 a2741b13dd258c843a2b9096f6b3aca3cb22647e2d5e6b18013857bbbb4e9aceccbc80713365aff0d25faa31727ff86ec4a86dac2dd8a556cb0a6dc3346f7be2 WHIRLPOOL 9044e85af7e9fadb9ce56f33d0ba63c5f39cbcf8dce2df4850474f03fde440c8ed1e52bc50e92804f4269e2d3c4563760512a23323e1120db3b7ea39d37ed211
diff --git a/gnome-extra/nemo/nemo-3.0.6.ebuild b/gnome-extra/nemo/nemo-3.0.6.ebuild
new file mode 100644
index 000000000000..7d3f0e573dff
--- /dev/null
+++ b/gnome-extra/nemo/nemo-3.0.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-any-r1 virtualx
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif +introspection +nls packagekit tracker xmp"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.3:2[dbus]
+ >=gnome-extra/cinnamon-desktop-2.6.1:0=
+ >=x11-libs/pango-1.28.3
+ >=x11-libs/gtk+-3.9.10:3[introspection?]
+ >=dev-libs/libxml2-2.7.8:2
+
+ gnome-base/dconf:0=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ exif? ( >=media-libs/libexif-0.6.20:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
+ tracker? ( >=app-misc/tracker-0.12:= )
+ xmp? ( >=media-libs/exempi-2.2.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+ nls? ( >=gnome-extra/cinnamon-translations-2.2 )
+"
+
+PDEPEND=">=gnome-base/gvfs-0.1.2"
+
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/polib[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ >=dev-lang/perl-5
+ >=dev-util/gdbus-codegen-2.31.0
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto
+
+ dev-util/gtk-doc
+ gnome-base/gnome-common
+"
+# For eautoreconf
+# gnome-base/gnome-common, dev-util/gtk-doc (not only -am!)
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-more-warnings \
+ $(use_enable exif libexif) \
+ $(use_enable introspection) \
+ $(use_enable tracker) \
+ $(use_enable xmp)
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/libnemo-private" || die
+
+ cd src # we don't care about translation tests
+ GSETTINGS_SCHEMA_DIR="${S}/libnemo-private" virtx emake check
+}