summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-06-27 23:56:16 +0300
committerMart Raudsepp <leio@gentoo.org>2020-06-28 00:03:16 +0300
commit2cc4f9257ef74ce629a7ea0e60a2a4f3bd3f41d3 (patch)
treea21a8a71c971b9e86ae4adc8dc51808f8e084181 /gnome-extra/nm-applet/nm-applet-1.18.0.ebuild
parentapp-misc/golly: port to python3 (diff)
downloadgentoo-2cc4f9257ef74ce629a7ea0e60a2a4f3bd3f41d3.tar.gz
gentoo-2cc4f9257ef74ce629a7ea0e60a2a4f3bd3f41d3.tar.bz2
gentoo-2cc4f9257ef74ce629a7ea0e60a2a4f3bd3f41d3.zip
gnome-extra/nm-applet: bump to 1.18.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/nm-applet/nm-applet-1.18.0.ebuild')
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.18.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/nm-applet-1.18.0.ebuild b/gnome-extra/nm-applet/nm-applet-1.18.0.ebuild
new file mode 100644
index 000000000000..49e66011c5f5
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.18.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="NetworkManager connection editor and applet"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="appindicator modemmanager selinux teamd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=app-crypt/libsecret-0.18
+ >=net-libs/libnma-1.8.27
+ >=x11-libs/gtk+-3.10:3
+ >=dev-libs/libgudev-147:=
+ >=x11-libs/libnotify-0.7.0
+ >=net-misc/networkmanager-1.16:=[modemmanager?,teamd?]
+ appindicator? (
+ dev-libs/libappindicator:3
+ >=dev-libs/libdbusmenu-16.04.0
+ )
+ modemmanager? ( net-misc/modemmanager )
+ selinux? ( sys-libs/libselinux )
+ teamd? ( >=dev-libs/jansson-2.7 )
+
+ virtual/freedesktop-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dappindicator=$(usex appindicator ubuntu no)
+ $(meson_use modemmanager wwan)
+ $(meson_use selinux)
+ $(meson_use teamd team)
+ -Dmore_asserts=0
+ -Dld_gc=false
+ )
+ meson_src_configure
+}