summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-04 18:37:51 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-04 18:37:51 +0200
commite4025fec7c32c17645fec83a1a6d02675693359c (patch)
tree4305e7d8cc4235ac47466f4432379de50274269d /gnome-extra/pch-session/pch-session-42.0.ebuild
parentnet-misc/r8168: add 8.050.00 (diff)
downloadgentoo-e4025fec7c32c17645fec83a1a6d02675693359c.tar.gz
gentoo-e4025fec7c32c17645fec83a1a6d02675693359c.tar.bz2
gentoo-e4025fec7c32c17645fec83a1a6d02675693359c.zip
gnome-extra/pch-session: add 42.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/pch-session/pch-session-42.0.ebuild')
-rw-r--r--gnome-extra/pch-session/pch-session-42.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnome-extra/pch-session/pch-session-42.0.ebuild b/gnome-extra/pch-session/pch-session-42.0.ebuild
new file mode 100644
index 000000000000..111755a3ad87
--- /dev/null
+++ b/gnome-extra/pch-session/pch-session-42.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Unofficial gnome based session with different default settings and extensions"
+HOMEPAGE="https://gitlab.com/pachoramos/pch-session"
+SRC_URI="https://gitlab.com/pachoramos/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth qt5 webp"
+
+RDEPEND="
+ >=gnome-base/gnome-shell-42
+ >=gnome-extra/gnome-shell-extensions-42
+ >=gnome-extra/gnome-shell-extension-alphabetical-grid-23.0
+ >=gnome-extra/gnome-shell-extension-appindicator-42
+ >=gnome-extra/gnome-shell-extension-applications-overview-tooltip-15
+ >=gnome-extra/gnome-shell-extension-bing-wallpaper-40
+ >=gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323
+ >=gnome-extra/gnome-shell-extension-dash-to-panel-47
+ >=gnome-extra/gnome-shell-extension-desktop-icons-ng-43.0
+ >=gnome-extra/gnome-shell-extension-gsconnect-50
+ >=gnome-extra/gnome-shell-extension-weather-in-the-clock-20211108-r1
+ >=gnome-extra/gnome-tweaks-40.10
+
+ gnome-extra/gnome-clocks
+ gnome-extra/seahorse-nautilus
+ >=media-fonts/fonts-meta-2
+
+ bluetooth? ( >=gnome-extra/gnome-shell-extension-bluetooth-quick-connect-29 )
+ qt5? ( x11-themes/adwaita-qt )
+ webp? ( gui-libs/gdk-pixbuf-loader-webp )
+"
+BDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ default
+ if ! use bluetooth; then
+ sed -i -e \
+ 's:"bluetooth-quick-connect@bjarosze.gmail.com",::g' \
+ usr/share/gnome-shell/modes/pch*.json || die
+ fi
+}
+
+pkg_preinst() {
+ gnome2_schemas_update
+}
+
+src_install() {
+ insinto /usr
+ doins -r usr/.
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}