summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 18:02:01 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 18:39:07 -0500
commit94a6c2311baa835bc476f81209100cb5926c9991 (patch)
treefb76f800aa9f4b28c39af6ca7a6351b0ab45fca7 /gnome-extra/sushi
parentapp-text/yelp-tools: Version bump to 41.0 (diff)
downloadgentoo-94a6c2311baa835bc476f81209100cb5926c9991.tar.gz
gentoo-94a6c2311baa835bc476f81209100cb5926c9991.tar.bz2
gentoo-94a6c2311baa835bc476f81209100cb5926c9991.zip
gnome-extra/sushi: Version bump to 41.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest1
-rw-r--r--gnome-extra/sushi/sushi-41.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index a518822a5e44..c6d0958e8372 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1 +1,2 @@
DIST sushi-3.38.1.tar.xz 79384 BLAKE2B 7306d375f85cc491fa8819e6857b1d61d158149045069002ed7a9c0f08c021ce0e9ed5ee751404a507dfdffdfa99895288f9c9601001818b4d1bc987f94bd823 SHA512 b999e6892314875725bd4029163ae58813b46f0e5c59e58b62fc4491d611b48fc39459f6c5b5e1a7d75d792cfeb66681f4d3a7057e8cde8f5c3364a2312e0be7
+DIST sushi-41.0.tar.xz 80940 BLAKE2B 211fb0c96ac0a911809007ed2e79659cc90a32be23d61137d85cc4502beb995d2131f62bbbb9a66f8da9328a4bf7d83b0c05f93e8913c8390be5cf22baaaeb00 SHA512 690018b846b23b3b21db244ae6e1f373870cc8cdb374dee2f4ba7eebf65af5d33a3366d37476b5f4556daf196c3f9cf8bf44903193831340f23ad33eef3ed484
diff --git a/gnome-extra/sushi/sushi-41.0.ebuild b/gnome-extra/sushi/sushi-41.0.ebuild
new file mode 100644
index 000000000000..0ce63af012ee
--- /dev/null
+++ b/gnome-extra/sushi/sushi-41.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="office wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+# Optional app-office/libreoffice support (OOo to pdf and then preview)
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ >=net-libs/webkit-gtk-2.34:4[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ office? ( app-office/libreoffice )
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_feature wayland) \
+ $(meson_feature X X11)
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}