summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-14 12:47:36 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-14 13:08:31 +0100
commit24c6425b14fcb1e6e4f9a2bf3cdda95c660c4c7b (patch)
tree0fe308b0187d3f56e4a9b25e64b6437b0fa01d7f /gnome-extra/yelp/yelp-3.30.0.ebuild
parentgnome-extra/yelp-xsl: 3.20.1 → 3.30.1 (diff)
downloadgentoo-24c6425b14fcb1e6e4f9a2bf3cdda95c660c4c7b.tar.gz
gentoo-24c6425b14fcb1e6e4f9a2bf3cdda95c660c4c7b.tar.bz2
gentoo-24c6425b14fcb1e6e4f9a2bf3cdda95c660c4c7b.zip
gnome-extra/yelp: 3.22.0 → 3.30.0
Add missing glib-utils to DEPEND. Closes: https://bugs.gentoo.org/668398 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'gnome-extra/yelp/yelp-3.30.0.ebuild')
-rw-r--r--gnome-extra/yelp/yelp-3.30.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/yelp/yelp-3.30.0.ebuild b/gnome-extra/yelp/yelp-3.30.0.ebuild
new file mode 100644
index 000000000000..28738ada777a
--- /dev/null
+++ b/gnome-extra/yelp/yelp-3.30.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-3.27.1
+ >=net-libs/webkit-gtk-2.19.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ eapply "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-bz2 \
+ --enable-lzma \
+ APPSTREAM_UTIL=""
+}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}