summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-26 15:27:24 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-26 16:28:35 +0100
commit0243efe68f2add43971c90c9497dd2d04ae9cc8b (patch)
treeb855dd4e493fca94b7aae73674e88679cae59645 /gnome-extra
parentdev-python/wrapt: add python herd (diff)
downloadgentoo-0243efe68f2add43971c90c9497dd2d04ae9cc8b.tar.gz
gentoo-0243efe68f2add43971c90c9497dd2d04ae9cc8b.tar.bz2
gentoo-0243efe68f2add43971c90c9497dd2d04ae9cc8b.zip
gnome-extra/cinnamon: Version bump, cjs-2.8 needed (#566900 by Marc Andi)
Package-Manager: portage-2.2.26
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon/Manifest1
-rw-r--r--gnome-extra/cinnamon/cinnamon-2.8.6.ebuild247
2 files changed, 248 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/Manifest b/gnome-extra/cinnamon/Manifest
index 10a13b85bcbb..25f364a060e6 100644
--- a/gnome-extra/cinnamon/Manifest
+++ b/gnome-extra/cinnamon/Manifest
@@ -1,2 +1,3 @@
DIST cinnamon-2.6.13.tar.gz 2967812 SHA256 f349403901bf3e84cda2ebd425dc6f58850059092775e285862067f120debe86 SHA512 41192b25ac34c542596f9625a671d019531aa466f057777da12ca0fda0f23daa10929c9f7a4e3c1a7137887fc9b0b556836a82f42645128b620949386387efec WHIRLPOOL 0c7c7ed6375964a93217adf43cc6236f7e7b92b75facfc94ded86f914890452b92753486d1c46b8a6531eef49993a0bc9fc0d387e8ea2a5bc4f05dd80571462a
DIST cinnamon-2.8.4.tar.gz 3025109 SHA256 4ae7ed062e2bfacabdac66002c14666c4709182d45a6f0140a577800e28b0326 SHA512 d2be926c17262c20aff7253b8fb25f7955328fbd7ee4271ec1f29d847c1768f1dffc90c1d9dd843c4bcd4a8a0503200b078e01d6dd6cc8fa66894f1b5fcd9a37 WHIRLPOOL a9726b360958799c6b8614b088acb0b38c544e5e78739d0e5f35e14d801d1aae32d0bc12064efd405eea01bddf6f5350f1e1298c2c11c10a07f27c54a2bc1566
+DIST cinnamon-2.8.6.tar.gz 3025161 SHA256 c262ae64320d4db8bffdfa7f05ab5a82449e96035b35dd8fb9353741323cb9a2 SHA512 fb683aaea1704eec5a1d2221d55c5e0e6530897f7aefc6ff9b9ff9d15818737a0d5d15aaa1d1f830e1f01e462324db026ac8c4475e39630cd6fd4a67dca9bddf WHIRLPOOL 488c215daf441be87d8f552bd4f0d8e55683286db143b2fbe5f8dd43a53df8e5c1e03b9230708ca149b85e3d9a93df58618b50afa014755a5ea943e33123edb8
diff --git a/gnome-extra/cinnamon/cinnamon-2.8.6.ebuild b/gnome-extra/cinnamon/cinnamon-2.8.6.ebuild
new file mode 100644
index 000000000000..62a193c98954
--- /dev/null
+++ b/gnome-extra/cinnamon/cinnamon-2.8.6.ebuild
@@ -0,0 +1,247 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+PYTHON_REQ_USE="xml"
+
+inherit autotools eutils flag-o-matic gnome2 multilib pax-utils python-r1
+
+DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+
+MY_PV="${PV/_p/-UP}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/linuxmint/Cinnamon/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+# bluetooth support dropped due bug #511648
+IUSE="+nls +networkmanager" #+bluetooth
+
+# We need *both* python 2.7 and 3.x
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ python_targets_python2_7
+ || ( python_targets_python3_3 python_targets_python3_4 python_targets_python3_5 )
+"
+
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-misc/ca-certificates
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.35.0:2[dbus]
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=dev-libs/json-glib-0.13.2
+ >=dev-libs/libcroco-0.6.2:0.6
+ dev-libs/libxml2:2
+ gnome-base/gconf:2[introspection]
+ gnome-base/librsvg
+ >=gnome-extra/cinnamon-desktop-2.4:0=[introspection]
+ gnome-extra/cinnamon-menus[introspection]
+ >=gnome-extra/cjs-2.8.0
+ >=media-libs/clutter-1.10:1.0[introspection]
+ media-libs/cogl:1.0=[introspection]
+ >=gnome-base/gsettings-desktop-schemas-2.91.91
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-sound/pulseaudio:0=[glib]
+ net-libs/libsoup:2.4[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.9.12:3[introspection]
+ x11-libs/pango[introspection]
+ >=x11-libs/startup-notification-0.11
+ x11-libs/libX11
+ >=x11-libs/libXfixes-5.0
+ >=x11-wm/muffin-2.5[introspection]
+ ${PYTHON_DEPS}
+ networkmanager? (
+ gnome-base/libgnome-keyring
+ >=net-misc/networkmanager-0.8.999[introspection] )
+"
+#bluetooth? ( >=net-wireless/gnome-bluetooth-3.1:=[introspection] )
+
+# Runtime-only deps are probably incomplete and approximate.
+# Each block:
+# 2. Introspection stuff + dconf needed via imports.gi.*
+# 3. gnome-session is needed for gnome-session-quit
+# 4. Control shell settings
+# 5. accountsservice is needed for GdmUserManager (0.6.14 needed for fast
+# user switching with gdm-3.1.x)
+# 6. caribou needed for on-screen keyboard
+# 7. xdg-utils needed for xdg-open, used by extension tool
+# 8. gconf-python, imaging, lxml needed for cinnamon-settings
+# 9. gnome-icon-theme-symbolic needed for various icons
+# 10. pygobject needed for menu editor
+# 11. nemo - default file manager, tightly integrated with cinnamon
+# 12. polkit-gnome - explicitly autostarted by us
+# TODO(lxnay): fix error: libgnome-desktop/gnome-rr-labeler.h: No such file or directory
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/dconf-0.4.1
+ >=gnome-base/libgnomekbd-2.91.4[introspection]
+ || ( sys-power/upower[introspection] sys-power/upower-pm-utils[introspection] )
+
+ >=gnome-extra/cinnamon-session-2.4
+ >=gnome-extra/cinnamon-settings-daemon-2.4
+
+ >=sys-apps/accountsservice-0.6.14[introspection]
+
+ >=app-accessibility/caribou-0.3
+
+ x11-misc/xdg-utils
+
+ dev-python/dbus-python[python_targets_python2_7]
+ dev-python/gconf-python:2[python_targets_python2_7]
+ dev-python/lxml[python_targets_python2_7]
+ dev-python/pexpect[python_targets_python2_7]
+ dev-python/pycairo[python_targets_python2_7]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyinotify[python_targets_python2_7]
+ dev-python/pypam[python_targets_python2_7]
+ dev-python/pillow[python_targets_python2_7]
+
+ x11-themes/gnome-themes-standard[gtk]
+ x11-themes/gnome-icon-theme-symbolic
+
+ >=gnome-extra/nemo-2.4
+ >=gnome-extra/cinnamon-control-center-2.4
+ >=gnome-extra/cinnamon-screensaver-2.4
+
+ gnome-extra/polkit-gnome
+
+ networkmanager? (
+ gnome-extra/nm-applet
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data )
+ nls? ( >=gnome-extra/cinnamon-translations-2.4 )
+"
+#bluetooth? ( net-wireless/cinnamon-bluetooth )
+
+DEPEND="${COMMON_DEPEND}
+ dev-python/polib[python_targets_python2_7]
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ !!=dev-lang/spidermonkey-1.8.2*
+"
+# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
+# https://bugs.gentoo.org/show_bug.cgi?id=360413
+
+S="${WORKDIR}/Cinnamon-${PV}"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ # Fix backgrounds path as cinnamon doesn't provide them
+ # https://github.com/linuxmint/Cinnamon/issues/3575
+ epatch "${FILESDIR}"/${PN}-2.8.0-background.patch
+
+ # Fix automagic gnome-bluetooth dep, bug #398145
+ epatch "${FILESDIR}"/${PN}-2.2.6-automagic-gnome-bluetooth.patch
+
+ # Optional NetworkManager, bug #488684
+ epatch "${FILESDIR}"/${PN}-2.6.7-optional-networkmanager.patch
+
+ # Use wheel group instead of sudo (from Fedora/Arch)
+ # https://github.com/linuxmint/Cinnamon/issues/3576
+ epatch "${FILESDIR}"/${PN}-2.8.3-set-wheel.patch
+
+ # Fix GNOME 3.14 support (from Fedora/Arch)
+ # https://github.com/linuxmint/Cinnamon/issues/3577
+ epatch "${FILESDIR}"/${PN}-2.8.3-gnome-3.14.patch
+
+ # Use pkexec instead of gksu (from Arch)
+ # https://github.com/linuxmint/Cinnamon/issues/3565
+ sed -i 's/gksu/pkexec/' files/usr/bin/cinnamon-settings-users || die
+
+ # Add polkit agent to required components (from Fedora/Arch), bug #523958
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ sed -i 's/RequiredComponents=\(.*\)$/RequiredComponents=\1polkit-gnome-authentication-agent-1;/' \
+ files/usr/share/cinnamon-session/sessions/cinnamon*.session || die
+
+ if ! use networkmanager; then
+ rm -rv files/usr/share/cinnamon/applets/network@cinnamon.org || die
+ fi
+
+ epatch_user
+
+ # python 2-and-3 shebang fixing craziness
+ local p
+ python_setup 'python3*'
+ for p in $(grep -rl '#!.*python3'); do
+ python_fix_shebang "${p}"
+ done
+
+ python_setup 'python2*'
+ for p in $(grep -rl '#!.*python[^3]'); do
+ python_fix_shebang "${p}"
+ done
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # https://bugs.gentoo.org/show_bug.cgi?id=536374
+ # https://github.com/linuxmint/Cinnamon/issues/3843
+ append-ldflags $(no-as-needed)
+
+ gnome2_src_configure \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --disable-rpath \
+ --disable-jhbuild-wrapper-script \
+ $(use_enable networkmanager) \
+ --with-ca-certificates="${EPREFIX}/etc/ssl/certs/ca-certificates.crt" \
+ BROWSER_PLUGIN_DIR="${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins" \
+ --without-bluetooth
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED}"usr/$(get_libdir)/cinnamon-*
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ pax-mark mr "${ED}usr/bin/cinnamon"
+
+ # Doesn't exist on Gentoo, causing this to be a dead symlink
+ rm -f "${ED}etc/xdg/menus/cinnamon-applications-merged" || die
+
+ # Ensure authentication-agent is started, bug #523958
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ insinto /etc/xdg/autostart/
+ doins "${FILESDIR}"/polkit-cinnamon-authentication-agent-1.desktop
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of Cinnamon's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "org.cinnamon.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version ">=x11-base/xorg-server-1.11"; then
+ ewarn "If you use multiple screens, it is highly recommended that you"
+ ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
+ ewarn "pointer barriers which will make it easier to use hot corners."
+ fi
+
+ if has_version "<x11-drivers/ati-drivers-12"; then
+ ewarn "Cinnamon has been reported to show graphical corruption under"
+ ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to"
+ ewarn "open-source drivers."
+ fi
+}