summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-01-12 03:05:43 +0200
committerMart Raudsepp <leio@gentoo.org>2017-01-12 03:09:08 +0200
commit03318fae0f6aed816d750ad6a0e49eca1f88d916 (patch)
tree248a4e69c8c74acd1de7c1e8f3a93962e3df89dd /gnome-extra
parentsys-kernel/hardened-sources: version bump to 4.8.17 (diff)
downloadgentoo-03318fae0f6aed816d750ad6a0e49eca1f88d916.tar.gz
gentoo-03318fae0f6aed816d750ad6a0e49eca1f88d916.tar.bz2
gentoo-03318fae0f6aed816d750ad6a0e49eca1f88d916.zip
gnome-extra/gnome-builder: Bump to 3.22.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-builder/Manifest1
-rw-r--r--gnome-extra/gnome-builder/gnome-builder-3.22.4.ebuild133
-rw-r--r--gnome-extra/gnome-builder/metadata.xml16
3 files changed, 146 insertions, 4 deletions
diff --git a/gnome-extra/gnome-builder/Manifest b/gnome-extra/gnome-builder/Manifest
index 53170cbdf624..67fec4b06486 100644
--- a/gnome-extra/gnome-builder/Manifest
+++ b/gnome-extra/gnome-builder/Manifest
@@ -1 +1,2 @@
DIST gnome-builder-3.18.1.tar.xz 1510460 SHA256 501c95220dcf8ca44a5748e863492377fe2c3aee78a95973d6819b1836e5407c SHA512 8e53b0d7a0afe440708bf33357408424cca5302e4516f85af18d04bce787012db681c93b6f48e9d41d8cb1a7c050d5e68770bf2e1ed8814ed43fa91e1d60c0f1 WHIRLPOOL d805338a3b49fe56794ddd9dca1ff047a4a9c87de24d06fed377637dba4e2ce8cf953cc8770e8745666dde1abfaabee9c68827631605a24e76e06148bed03f5b
+DIST gnome-builder-3.22.4.tar.xz 2480900 SHA256 d569446a83ab88872c265f238f8f42b5928a6b3eebb22fd1db3dbc0dd9128795 SHA512 69ee0d22f7e60f1bc236f2648662ece38f2a3c827d6877f8cbee82eadd499c19de8e4f6f94d7ad8832a93d26cddb5d34106ec6a9e878a7abea3350929d50711d WHIRLPOOL 9dd3f91d6f66a30e9ff6b415683f9a024d38f4af53029bb9fb4e5b3bf73f06c303516b4958585d7743ffb62cbb468da76b2a9c996ee460539762fada4c11a4da
diff --git a/gnome-extra/gnome-builder/gnome-builder-3.22.4.ebuild b/gnome-extra/gnome-builder/gnome-builder-3.22.4.ebuild
new file mode 100644
index 000000000000..1a6e8fb4b25a
--- /dev/null
+++ b/gnome-extra/gnome-builder/gnome-builder-3.22.4.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+VALA_MIN_API_VERSION="0.30"
+VALA_USE_DEPEND="vapigen"
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+
+inherit gnome2 python-single-r1 vala virtualx readme.gentoo-r1
+
+DESCRIPTION="Builder attempts to be an IDE for writing software for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Builder"
+
+# FIXME: Review licenses at some point
+LICENSE="GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clang +git sysprof vala webkit"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# When bumping, pay attention to all the included plugins/*/configure.ac files and the requirements within.
+# Most have no extra requirements and default to enabled; we need to handle the ones with extra requirements, which tend to default to auto(magic).
+# Look at the last (fourth) argument given to AC_ARG_ENABLE to decide. We don't support any disabling of those that are default-enabled and have no extra deps beyond C/python/introspection.
+# FIXME: >=dev-util/devhelp-3.20.0 dependency is automagic for devhelp integration plugin
+# FIXME: vte could be optional via $(use_enable vte terminal-plugin) - but most/all people want this and have vte?
+# FIXME: flatpak-plugin needs flatpak.pc >=0.6.9, libgit2[threads] >=libgit2-glib-0.24.0[ssh] libsoup-2.4.pc
+# FIXME: --with-sanitizer configure option
+# FIXME: Enable rdtscp based high performance counter usage on suitable architectures for EGG_COUNTER?
+# Editorconfig needs pcre.h, with vte migrating away, might want it optional?
+# Python is always enabled - the core python plugin support checks are automagic and not worth crippling it by not supporting python plugins
+# Relatedly introspection is always required to not have broken python using plugins or have to enable/disable them based on it. This is a full IDE, not a place to be really minimal.
+# An introspection USE flag of a dep is required if any introspection based language plugin wants to use it. Last full check at 3.22.4
+RDEPEND="
+ >=x11-libs/gtk+-3.22.1:3[introspection]
+ >=dev-libs/glib-2.50.0:2[dbus]
+ >=x11-libs/gtksourceview-3.22.0:3.0[introspection]
+ >=dev-libs/gobject-introspection-1.48.0:=
+ >=dev-python/pygobject-3.22.0:3
+ >=dev-libs/libxml2-2.9
+ >=x11-libs/pango-1.38.0
+ >=dev-libs/libpeas-1.18.0
+ >=dev-libs/json-glib-1.2.0
+ webkit? ( >=net-libs/webkit-gtk-2.12.0:4=[introspection] )
+ clang? ( sys-devel/clang )
+ git? (
+ dev-libs/libgit2[ssh,threads]
+ >=dev-libs/libgit2-glib-0.24.0[ssh] )
+ >=x11-libs/vte-0.46:2.91
+ sysprof? ( >=dev-util/sysprof-3.22.2[gtk] )
+ dev-libs/libpcre:3
+ ${PYTHON_DEPS}
+ vala? ( $(vala_depend) )
+"
+# desktop-file-utils for desktop-file-validate check in configure for 3.22.4
+# mm-common due to not fully clean --disable-idemm behaviour, recheck on bump
+DEPEND="${RDEPEND}
+ dev-cpp/mm-common
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ >=dev-util/gtk-doc-am-1.11
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ !<sys-apps/sandbox-2.10-r3
+"
+
+# Tests fail if all plugins aren't enabled (webkit, clang, devhelp, perhaps more)
+RESTRICT="test"
+
+DOC_CONTENTS='gnome-builder can use various other dependencies on runtime to provide
+extra capabilities beyond these expressed via USE flags. Some of these
+that are currently available with packages include:
+
+* dev-util/ctags with exuberant-ctags selected via "eselect ctags" for
+ C, C++, Python, JavaScript, CSS, HTML and Ruby autocompletion, semantic
+ highlighting and symbol resolving support.
+* dev-python/jedi and dev-python/lxml for more accurate Python
+ autocompletion support.
+* dev-util/meson for integration with the Meson build system.
+* dev-util/cargo for integration with the Rust Cargo build system.
+'
+# FIXME: Package gnome-code-assistance and mention here, or maybe USE flag and default enable because it's rather important
+# jhbuild support
+# rust language server via rls
+# autotools stuff for autotools plugin
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ export PYTHON3_CONFIG="$(python_get_PYTHON_CONFIG)"
+ # idemm is C++ wrapper for libide. Once that's needed by something, we might want to
+ # consider a split package instead of USE flag. Deps are in libidemm/configure.ac
+ gnome2_src_configure \
+ --disable-idemm \
+ --enable-editorconfig \
+ --enable-introspection \
+ $(use_enable vala vala-pack-plugin) \
+ $(use_enable webkit) \
+ $(use_enable webkit html-preview-plugin) \
+ $(use_enable clang clang-plugin) \
+ $(use_enable git git-plugin) \
+ $(use_enable git contributing-plugin) \
+ $(use_enable sysprof sysprof-plugin) \
+ --disable-flatpak-plugin \
+ --enable-terminal-plugin \
+ --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data/gsettings" || die
+
+ GSETTINGS_SCHEMA_DIR="${S}/data/gsettings" virtx emake check
+}
diff --git a/gnome-extra/gnome-builder/metadata.xml b/gnome-extra/gnome-builder/metadata.xml
index 996e7cacd217..78c212429a5c 100644
--- a/gnome-extra/gnome-builder/metadata.xml
+++ b/gnome-extra/gnome-builder/metadata.xml
@@ -1,8 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="clang">Provide integration with <pkg>sys-devel/clang</pkg> for best possible C/C++ autocompletion, semantic highlighting, symbol resolving, and diagnostics support</flag>
+ <flag name="git">Provide support for the Git version control system via <pkg>dev-libs/libgit2-glib</pkg>
+ (such as setup of Git for New Project, direct cloning for Open Project and changed lines indicators in the editor gutter)</flag>
+ <flag name="sysprof">Provide an integrated profiler via <pkg>dev-util/sysprof</pkg></flag>
+ <flag name="vala">Provide an autoindenter, autocompletion, diagnostics, and symbol resolver for Vala</flag>
+ <flag name="webkit">Enable <pkg>net-libs/webkit-gtk</pkg> using plugins support and the HTML/Markdown previewer plugin</flag>
+</use>
</pkgmetadata>