summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-10 17:16:12 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-10 17:16:25 -0500
commit154cf4048e523be57dc68d43af5c449dc561b194 (patch)
tree711ba44a3925aa89279d0370e7c782007d491f17 /gnome-extra
parentlicenses: Remove unused. (diff)
downloadgentoo-154cf4048e523be57dc68d43af5c449dc561b194.tar.gz
gentoo-154cf4048e523be57dc68d43af5c449dc561b194.tar.bz2
gentoo-154cf4048e523be57dc68d43af5c449dc561b194.zip
gnome-extra/nm-applet: bump to 1.8.6
Package-Manager: Portage-2.3.13_p1, Repoman-2.3.3_p81
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nm-applet/Manifest1
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.8.6.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/Manifest b/gnome-extra/nm-applet/Manifest
index 47a8f5212e0a..25ca6191bb2b 100644
--- a/gnome-extra/nm-applet/Manifest
+++ b/gnome-extra/nm-applet/Manifest
@@ -1,2 +1,3 @@
DIST network-manager-applet-1.4.6.tar.xz 1388916 SHA256 10a6fcfe8c6206cf18ec78a522a716b5ec9d0b7ca1e7d234c638725b316fec76 SHA512 f0eab5c50739c2309fa19336e23ead6603dc953b62fff0600a91988df8d41c2f300c22ebd4d5be8654a3fd7bac38dacc23be149f1a7085f10bb55e1830d9472f WHIRLPOOL f04c5bcf0796539b37fc1b83f81151be2fa68bb078209555196840617332ac8e624cc5911c9932b1768764c2bd696c613c760681d543f8e8e28d0f7f0bc7e221
DIST network-manager-applet-1.8.2.tar.xz 1445920 SHA256 3e57e9cf545a336da7035af1ba6171900ebc023ef19a594fe170da64af84c925 SHA512 1e9019ca17a55138e08eaf34c7889b7d5f531e918412bf025c0e03eb0794dc323b59f0d3521f14e93b6a94756f8e2a52139c76117ed430c73bcd1366eeffb5c9 WHIRLPOOL 1f711907c0f0265b25b79b17681c8c666129699362d0dec11eac0413b0f9d9be322f4a0e2a760d586cb769c5446eb1fc191d4459be45a39f3c37e11ee738d495
+DIST network-manager-applet-1.8.6.tar.xz 1478992 SHA256 01749e2c27d84ac858f59bc923af50860156eb510e2b6cf7d4941f753bef9c30 SHA512 9080fe1ef252837f16c698fe2083ebe66949e2a30f626619ef7eb82f44e988a0b8488f4f8cd0946a78a240f9bf7a5d054afc988b25c1bedeba7f79a7c84d46fa WHIRLPOOL de81ff0743432e183f771719abc38dadd3d01293cbe0bcc1c762cc0f4f5f80263700f6e12feb840d66e5e89cd1347c8988e7205e11f98903ec02ed3de760e244
diff --git a/gnome-extra/nm-applet/nm-applet-1.8.6.ebuild b/gnome-extra/nm-applet/nm-applet-1.8.6.ebuild
new file mode 100644
index 000000000000..a937ab737f58
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.8.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome2
+
+DESCRIPTION="GNOME applet for NetworkManager"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection gcr +modemmanager selinux teamd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-crypt/libsecret-0.18
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/dbus-glib-0.88
+ >=sys-apps/dbus-1.4.1
+ >=sys-auth/polkit-0.96-r1
+ >=x11-libs/gtk+-3.4:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+
+ app-text/iso-codes
+ >=net-misc/networkmanager-1.7:=[introspection?,modemmanager?,teamd?]
+ net-misc/mobile-broadband-provider-info
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+ virtual/freedesktop-icon-theme
+ virtual/libgudev:=
+ gcr? ( >=app-crypt/gcr-3.14:=[gtk] )
+ modemmanager? ( net-misc/modemmanager )
+ selinux? ( sys-libs/libselinux )
+ teamd? ( >=dev-libs/jansson-2.3 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.0
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+"
+
+PDEPEND="virtual/notification-daemon" #546134
+
+src_configure() {
+ local myconf=(
+ --without-appindicator
+ --disable-lto
+ --disable-ld-gc
+ --disable-more-warnings
+ --disable-static
+ --localstatedir=/var
+ $(use_enable introspection)
+ $(use_with gcr)
+ $(use_with modemmanager wwan)
+ $(use_with selinux)
+ $(use_with teamd team)
+ )
+ gnome2_src_configure "${myconf[@]}"
+}