summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-01 09:12:00 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-01 11:04:36 -0400
commit28d01fabb1b13cb9716703e4b0e7f2c312df64a1 (patch)
tree7d911f17910a2a8d6ab41c3ce2e55b89238a1a9d /gnome-extra
parentgnome-base/gnome-shell: Version bump to 44.4 (diff)
downloadgentoo-28d01fabb1b13cb9716703e4b0e7f2c312df64a1.tar.gz
gentoo-28d01fabb1b13cb9716703e4b0e7f2c312df64a1.tar.bz2
gentoo-28d01fabb1b13cb9716703e4b0e7f2c312df64a1.zip
gnome-extra/gnome-software: Version bump to 45_rc
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32549 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-software/Manifest1
-rw-r--r--gnome-extra/gnome-software/gnome-software-45_rc.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/gnome-extra/gnome-software/Manifest b/gnome-extra/gnome-software/Manifest
index f446a8dc09e3..ca96e4e2c33f 100644
--- a/gnome-extra/gnome-software/Manifest
+++ b/gnome-extra/gnome-software/Manifest
@@ -1,2 +1,3 @@
DIST gnome-software-44.4.tar.xz 2426404 BLAKE2B 6f60ffd115ad0e11b619118ae5e665fb35c70621adefe4c532481ab3742c8e2c6a5a0790dae29b2fcf0311f89fda93c323e5bc24b185bbbe95e62a687f71930d SHA512 97eaa33b4dd91a6865ee7eeee28e5acf3cf5fbd6a72a60cf5a7c528f79f6f0684014d1169318314b8efce23c1c29e7d24a71193998ced930584a50494137cf8b
DIST gnome-software-45.beta.tar.xz 2450776 BLAKE2B b14af00c87682a56a54b3cba394be57e0994a56671ccbb2016aecd492401f54e068973f7bd6278c1b55f02f0d8e1ef9de9d3408dbe2ff30634c9f78e80be044b SHA512 d4218b56478c9e7e83adf4fb8daec8d0730f5ce16cca0a0c59962894a0abb2d21c356a55f232d266aaaa4f15b21c21bc5904cc1f7b6db4d94db8889019fea092
+DIST gnome-software-45.rc.tar.xz 2466120 BLAKE2B e8d741872831f8259ce6b1dc6472250544a6aaa5c412464ddf103839fcf6907e752ae261d9ac78215d069e05bcdd2acfc0673f0db647b00f506f9206d9410843 SHA512 674c89619419cb7622bed3ce1453c31460d51ba6716db3d8bfc79829ca619e24d1f9c954f2fe72d96156e2e6dbaaf151faa29c97425b0cac132ec3e49871fb79
diff --git a/gnome-extra/gnome-software/gnome-software-45_rc.ebuild b/gnome-extra/gnome-software/gnome-software-45_rc.ebuild
new file mode 100644
index 000000000000..3ae5fd156fec
--- /dev/null
+++ b/gnome-extra/gnome-software/gnome-software-45_rc.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Gnome install & update software"
+HOMEPAGE="https://wiki.gnome.org/Apps/Software https://gitlab.gnome.org/GNOME/gnome-software"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="flatpak +firmware gnome gtk-doc sysprof udev test"
+
+RDEPEND="
+ >=dev-libs/appstream-0.14.0:0=
+ >=x11-libs/gdk-pixbuf-2.32.0:2
+ >=dev-libs/libxmlb-0.1.7:=
+ >=gui-libs/gtk-4.10.0:4
+ >=dev-libs/glib-2.70.0:2
+ >=dev-libs/json-glib-1.6.0
+ >=net-libs/libsoup-3.0:3.0
+ >=gui-libs/libadwaita-1.3_rc:1
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ gnome? ( >=gnome-base/gsettings-desktop-schemas-3.18.0 )
+ sys-auth/polkit
+ firmware? ( >=sys-apps/fwupd-1.5.6 )
+ flatpak? (
+ >=sys-apps/flatpak-1.14.0-r1
+ dev-util/ostree
+ )
+ udev? ( dev-libs/libgudev )
+ >=gnome-base/gsettings-desktop-schemas-3.11.5
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/libglib-testing )
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ sed -i -e '/install_data.*README\.md.*share\/doc\/gnome-software/d' meson.build || die
+ # We don't need language packs download support, and it fails tests in 3.34.2 for us (if they are enabled)
+ sed -i -e '/subdir.*fedora-langpacks/d' plugins/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_feature gnome gsettings_desktop_schemas) # Honoring of GNOME date format settings.
+ -Dman=true
+ -Dpackagekit=false
+ # -Dpackagekit_autoremove
+ -Dpolkit=true
+ -Deos_updater=false # Endless OS updater
+ $(meson_use firmware fwupd)
+ $(meson_use flatpak)
+ -Dmalcontent=false
+ -Drpm_ostree=false
+ -Dwebapps=true
+ -Dhardcoded_foss_webapps=true
+ -Dhardcoded_proprietary_webapps=true
+ $(meson_use udev gudev)
+ -Dapt=false
+ -Dsnap=false
+ -Dexternal_appstream=false
+ $(meson_use gtk-doc gtk_doc)
+ -Dhardcoded_curated=true
+ # TODO: Will this be beneficial to us with flatpak at least? If
+ # enabled, it shows some apps under installed (probably merely due to
+ # /usr/share/app-info presence), but launching and removal of them is
+ # broken
+ -Ddefault_featured_apps=false
+ -Dmogwai=false #TODO?
+ $(meson_feature sysprof)
+ -Dprofile=''
+ -Dsoup2=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}