summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-06-11 20:21:20 +0200
committerPacho Ramos <pacho@gentoo.org>2021-06-11 20:34:32 +0200
commit2994c3b7e53278c02514bbb1e6d0c934189a0425 (patch)
tree806de708b73a21cd8719ef6a78bb1984183213c0 /gnome-extra
parentdev-python/spyder-kernels: drop version 2.0.3 (diff)
downloadgentoo-2994c3b7e53278c02514bbb1e6d0c934189a0425.tar.gz
gentoo-2994c3b7e53278c02514bbb1e6d0c934189a0425.tar.bz2
gentoo-2994c3b7e53278c02514bbb1e6d0c934189a0425.zip
gnome-extra/gnome-shell-extension-appindicator: Bump to v40
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-40.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/Manifest b/gnome-extra/gnome-shell-extension-appindicator/Manifest
index 3ac5c640bfc1..d479940a68b6 100644
--- a/gnome-extra/gnome-shell-extension-appindicator/Manifest
+++ b/gnome-extra/gnome-shell-extension-appindicator/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-appindicator-34.tar.gz 34764 BLAKE2B 3a619f810d9ddf7984fc3b0c96735eb0f9233f36ff3cbddc5b28a8243f55d57cbc9c58b49516e99b30f35b12b6e747b7fa288fdc36f99cf7e61b7ad8cc2e84de SHA512 1f02a7cc3cfb90af8ee1a0bb39135fb3203bcc87d13cda0cf7f110db4b838a7c082eba30246a913306ef0e4b2fdb7c9f52f24f62525013ff8f1de9d054d45425
DIST gnome-shell-extension-appindicator-37.tar.gz 39830 BLAKE2B 6e8af3acf6c9a4478fd663aa5814fae5a59e5ed01a759d7aa37d056794c3ea6c595203b622087f02170d9f05e6fa1c47138da9962ae33d9f398a7659a645be57 SHA512 2aeb93ca015936577f314e0313dd963d3712edf27a5e9721813b6d72b5050de9427d7aa3a296ced40352a421251ecae7022fb58c1da02947bc0a6205e2d41d1b
+DIST gnome-shell-extension-appindicator-40.tar.gz 48681 BLAKE2B cec52930bcb163a6761662deb3bd52202abadfc90fdd12877c711e4f4cf5038b9e7f3822259ced5ba39a632d2a1e0a83ffc4dc563ba184742dd1de2941acfe73 SHA512 72b3ecf0eadde40fd3567b19d7c7064953847ec86298691097f9fe14cada37206f8edd898c1d2a8fe71aeb0ace4921d1797d2dcc9eeacc0cb04a25841125b2ef
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-40.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-40.ebuild
new file mode 100644
index 000000000000..12e3b6cddea6
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-40.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Support Ubuntu AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ dev-libs/libappindicator:3
+ >=gnome-base/gnome-shell-3.34
+"
+DEPEND=""
+BDEPEND=""
+
+extension_uuid="appindicatorsupport@rgcjonas.gmail.com"
+
+src_install() {
+ einstalldocs
+ dodoc AUTHORS.md
+
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+
+ rm -rf schemas/ AUTHORS.md LICENSE Makefile README.md || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}