summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-12-01 23:06:42 +0100
committerPacho Ramos <pacho@gentoo.org>2020-12-01 23:15:20 +0100
commit2f55937292a2c280f70588444919369f0a368a74 (patch)
treed2c9fa7126cb6ce32f3141cd384a08e85ee3af06 /gnome-extra
parentgnome-extra/gnome-shell-extension-appindicator: Bump to v34 (diff)
downloadgentoo-2f55937292a2c280f70588444919369f0a368a74.tar.gz
gentoo-2f55937292a2c280f70588444919369f0a368a74.tar.bz2
gentoo-2f55937292a2c280f70588444919369f0a368a74.zip
gnome-extra/gnome-shell-extension-applications-overview-tooltip: Bump to v10
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-10.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index 0e98ec0e03ae..917076706c5f 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1,2 +1,3 @@
+DIST gnome-shell-extension-applications-overview-tooltip-10.tar.gz 81397 BLAKE2B a9c838eb66ae49a3a195d8ce6e17fd971fb0dec00f62a2a7380fc973c9ba129611a93b904c658318e0bc80fb26ff9d65100cccd29f7f172dbef0f406bacefd14 SHA512 28bcc52b38d36e0897c949ba0eef11a94fce2e022ca3d398208221476b63b39281db9870d0c26a4bdffc07bb82e9d8942fd98820c78c6a4afe6d52eb5758e1c1
DIST gnome-shell-extension-applications-overview-tooltip-7.tar.gz 79965 BLAKE2B f7698bdad46837f1ae736bbb2d9b376a28946df5f8a00d2e9b19d48bc4c2f4e742030f952d14bf5816ca1aae9b172a2639e2170d6bd87f373ff23c7ce9bd8912 SHA512 1cfaf23fefe5a940ae448658e176c69da9bb319f6200983b4ac14f65e76f5e449b9a235e6c1ccaf9b6d6db0fda9576e963fa1273b776dbfb5a72c608961e2d48
DIST gnome-shell-extension-applications-overview-tooltip-9.tar.gz 81415 BLAKE2B 518352e80b5a3c6f8a2ff05e692178436625ea533e10a2afde82e73b6216f82dc29119c0e0a204ac8f1619de9409c47105107b94e3c4d1027c852b255eeb27ab SHA512 b8a2879f303a76e68eb5921005453e3fb73d966f1ed3f5978d9d210f447d8f780b5d9fa359aaa411f7ed8cecf72171dfcaa8da8515fd620193676b1b63742636
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-10.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-10.ebuild
new file mode 100644
index 000000000000..2f000f6faee8
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+"
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md schemas || die
+ insinto /usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}