summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-07 18:09:51 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-07 18:10:57 -0400
commit3d520bfae7589583fa77ee6315b877bdb35bc789 (patch)
treef1f1c5c5d1bee172a047b0dc9326ee2536a39b60 /gnome-extra
parentgnome-base/gvfs: Version bump to 1.50.5 (diff)
downloadgentoo-3d520bfae7589583fa77ee6315b877bdb35bc789.tar.gz
gentoo-3d520bfae7589583fa77ee6315b877bdb35bc789.tar.bz2
gentoo-3d520bfae7589583fa77ee6315b877bdb35bc789.zip
gnome-extra/gnome-user-docs: Version bump to 44.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index 94f54ba8bb1d..f72e40570648 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1 +1,2 @@
DIST gnome-user-docs-44.1.tar.xz 13297308 BLAKE2B 4e6c15d7511157c677d578804c883b7af3e8961cb9edfc192a51ef5d79020f638759c54d1f4ea26799bd59a8c008cf88e5432e1393ceaa82dfd4e9aab45b8d43 SHA512 9f1351232d09249ec21c9574e4d691e77eabf3840eb41242afeb44243049ffdc3ee3a064ef36962eb5418c4445c23be27675fdd2c1d71c758a3564419a1fd950
+DIST gnome-user-docs-44.3.tar.xz 13364796 BLAKE2B 2a8d23154d08c18a699691451f5c37fd6729a6da8ed53b40478f929260fac2c77c01388edbb12edef7e142a322acb163466166aceaa35594143b214e87dabb4c SHA512 c61967958e3d0447d69cc89381896697489e144c3bc3090e1d62cc385a6a7d94501172a11536ba591912a1f8c37c2ef5f8cb299b105f3ac2eabd637fdaa38fdd
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild
new file mode 100644
index 000000000000..f5c2e5bd8bf7
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}