summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-22 23:25:33 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-22 23:44:31 -0700
commit4c950ca51cec3047a99a19f589a3d2c374bd551c (patch)
tree1d1720249ff458dace86f3c259b13384f7715db1 /gnome-extra
parentmail-client/evolution: Version bump to 3.44.0 (diff)
downloadgentoo-4c950ca51cec3047a99a19f589a3d2c374bd551c.tar.gz
gentoo-4c950ca51cec3047a99a19f589a3d2c374bd551c.tar.bz2
gentoo-4c950ca51cec3047a99a19f589a3d2c374bd551c.zip
gnome-extra/evolution-ews: Version bump to 3.44.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 30b0b115a80d..1979b9ac7ca3 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1 +1,2 @@
DIST evolution-ews-3.42.4.tar.xz 686236 BLAKE2B f68a3c4c41419eb5d316ce8271a8c8411217e63b951230fb0151d79fca15e82e36248e3bd676518ae5f8a92d7e1d1dbf6a140bbd63dee6dca97fe48f76d502f9 SHA512 5ce1a228414d8c456962ce944a01efbeefb059bc9ff358c95bb7cec72e74ad29cd9476c9aa396b01df35d7c89fff743837dc2f9763129a5f794cbbd14557c2e3
+DIST evolution-ews-3.44.0.tar.xz 688444 BLAKE2B d563137c481dc51f9934fe44a3c563e7204d63ebdac1de7a018da27f8c05cc3d56ddc37848fb57ed909e6bc4d98e2752d401f39e92ccd20b507033404c6b7284 SHA512 0625262e485edf7dc5a0449acae3d65992d4f17dcc64196e449922e3eeb4c8ce57cf0220ecf626bcfcd81b5cea1273ccde18f0dbb9073f56ee923a3cbfb93a83
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild
new file mode 100644
index 000000000000..72c04608688e
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}