summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-07 23:51:23 +0000
committerSam James <sam@gentoo.org>2024-03-07 23:51:23 +0000
commit543b29a483d45bc5f7a48608ee40665a96ad1b12 (patch)
treec327e1b8189a9b57be13c9035af751722753f7b1 /gnome-extra
parentgui-libs/vte-common: filter LTO (diff)
downloadgentoo-543b29a483d45bc5f7a48608ee40665a96ad1b12.tar.gz
gentoo-543b29a483d45bc5f7a48608ee40665a96ad1b12.tar.bz2
gentoo-543b29a483d45bc5f7a48608ee40665a96ad1b12.zip
gnome-extra/gucharmap: filter LTO
Upstream don't support LTO & error out on it in meson.build. Closes: https://bugs.gentoo.org/926250 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.0.4.ebuild7
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.1.1.ebuild7
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.1.2.ebuild7
3 files changed, 15 insertions, 6 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild b/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
index d5cda00d943f..b788ccd08f8a 100644
--- a/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit gnome2-utils meson python-any-r1 vala xdg
+inherit flag-o-matic gnome2-utils meson python-any-r1 vala xdg
DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
@@ -50,6 +50,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926250)
+ filter-lto
+
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3
diff --git a/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild b/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild
index 5eaba63f4112..74d609904765 100644
--- a/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome2-utils meson python-any-r1 vala xdg
+inherit flag-o-matic gnome2-utils meson python-any-r1 vala xdg
DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
@@ -52,6 +52,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926250)
+ filter-lto
+
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3
diff --git a/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild b/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild
index 5eaba63f4112..74d609904765 100644
--- a/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome2-utils meson python-any-r1 vala xdg
+inherit flag-o-matic gnome2-utils meson python-any-r1 vala xdg
DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
@@ -52,6 +52,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926250)
+ filter-lto
+
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3