summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-02 18:25:51 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-04 11:46:14 -0400
commit6461f8d2783a07e9f43b263d70652b16519430f7 (patch)
treea49317cdd3ac6cb28d50800aaf1bc37e0a5330c0 /gnome-extra
parentgnome-base/nautilus: Version bump to 45_rc (diff)
downloadgentoo-6461f8d2783a07e9f43b263d70652b16519430f7.tar.gz
gentoo-6461f8d2783a07e9f43b263d70652b16519430f7.tar.bz2
gentoo-6461f8d2783a07e9f43b263d70652b16519430f7.zip
gnome-extra/gnome-system-monitor: Version bump to 45.0.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32570 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-45.0.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index 858bb2921a22..5d6f8238d2b5 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1,3 +1,4 @@
DIST gnome-system-monitor-44.0.tar.xz 1012688 BLAKE2B b9e537ac865c31e0aa05958f067181bf3ef73e4997e818ec4d5d61da65954e910c908901ed55cceac447798d092944a01999fc37f38c7ce51590efedf7f12a85 SHA512 052dcdc927ad53ea601f1f3da6a921fe21b04f69aaa8b75a5096fdcdac5706391180c476b5c87a98012fa7b5dc6c5c43b8c88c30a38b12868c4188020e8ec3b8
+DIST gnome-system-monitor-45.0.1.tar.xz 1018808 BLAKE2B 0c226da9e930aa9d4700c4ce074831aaffef57acd19a0d234c1a2a5fdda97b490b55b9959a709fee2848261ce72b063f595eae34697c49ff3fcfc3dc591be8e8 SHA512 116b6d2248eb9723d74f2029ce55aaa016a856f648349eceeecb486965fd5785f90b32dd3fcc09729e4ab34f2d87b40324cbf98d2e4523fa56f59f948531fcb5
DIST gnome-system-monitor-45.0.tar.xz 1017804 BLAKE2B 6a221021870d647a64d84437741c107333004a7f82c95752e0157a17dd2c3de11f5f828603a5523f04159da2c2897fae173059d0c42821fa74afce8dc117f159 SHA512 b30fe7ad4507e57138026f1414735c5c833e83c55a1eabb608dab6a628087571aec7a36cd41e11f1bba9d232771477327ea3470343357a1213ed7d8871d9f646
DIST gnome-system-monitor-45.beta.tar.xz 1015144 BLAKE2B 77f1a731685802055732265fbb3570b5d34d03dcfa290e9f631c8e72b5c5a8a978a040d3de12244404cf2936887c75dbd1533c6e260548865400bb838698bfb2 SHA512 8c50335af30eae6364c3dcf03a8f0f5468f2c049d1c5466fe6c106819d933587a78cf77a47fe55fb66a30b519dbbb4187e3bc34f8665ace3824080d1b9f2d80d
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-45.0.1.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-45.0.1.ebuild
new file mode 100644
index 000000000000..d9c9360329f7
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-45.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22:3[X(+)?]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/atkmm-2.28:0
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gui-libs/libhandy-1.5.0:1
+ >=gnome-base/librsvg-2.35:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}