summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-08-28 00:37:05 +0300
committerMart Raudsepp <leio@gentoo.org>2019-08-28 00:37:27 +0300
commit648c3680c69dcfb926512350261ec714ea7ac3a4 (patch)
treee33c4a1f4026ead956fa1c80b53a50f6bc3e488d /gnome-extra
parentapp-emulation/fs-uae: Fix missing X11/Xatom.h include (diff)
downloadgentoo-648c3680c69dcfb926512350261ec714ea7ac3a4.tar.gz
gentoo-648c3680c69dcfb926512350261ec714ea7ac3a4.tar.bz2
gentoo-648c3680c69dcfb926512350261ec714ea7ac3a4.zip
gnome-extra/libgsf: bump to 1.14.46
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.46.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index 5a4594eb6509..02a77f76a5ab 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1,2 +1,3 @@
DIST libgsf-1.14.43.tar.xz 618272 BLAKE2B a381125ce75d06ae4bf1c9dbe9b2e207534ff7c3310e40984e482bc5120eae45a7e3ed4cfd878890037f31ee540c700dea3120119b9a533fa79cab317a0c83a8 SHA512 bb487de9358c057fc73f3414c9515726315be9b6d78456253daaca1cbd58281de8766e0b72914532d63fab04d3ae2cf90f711f436c7b4f70620d77e8a7802ac9
DIST libgsf-1.14.45.tar.xz 618476 BLAKE2B f577859578de6ca359a7377dcced424e95779d3fd155cdbeb1c2874f7a0d0c7a09a2322d2538452b48798ea979e8260be77215140f298dc58ee32a0b9ead0e47 SHA512 2e993150b6fec336a14fd85d5c631e4a3b43187039dab0cba3b8badf62873f39814392db92bb737b92aa9a6d8b4ba41f1fb248c1fe07b88cddd28ded5e4d9ebd
+DIST libgsf-1.14.46.tar.xz 689360 BLAKE2B d5d66e96dc74fa68111781ce9bcbfaed2b8a99f9d2bcb16e32a650e103716633b5def7c93f133538449a3b6d9299e4709ba29bc6a520d5c7fe144bcbf78d3ae1 SHA512 130331f63d48455cc2ce60756e2ac703f8a7f5fa8f1243d9d9321fb87e01bf1d616d085d100a3e5d1cf34fb851ffb77bc642aff6c674ace167b9aa117f4fb1b0
diff --git a/gnome-extra/libgsf/libgsf-1.14.46.ebuild b/gnome-extra/libgsf/libgsf-1.14.46.ebuild
new file mode 100644
index 000000000000..1f6481f81894
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.46.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}