summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-10-20 20:50:02 +0300
committerMart Raudsepp <leio@gentoo.org>2019-10-20 20:50:02 +0300
commit7116780256ba1bf5a294ad8b08c53a8c30d506fb (patch)
tree0f98bf847652eb95de430e718783c5696cd0dda1 /gnome-extra
parentgnome-base/gnome-extra-apps: bump to 3.32.2 (diff)
downloadgentoo-7116780256ba1bf5a294ad8b08c53a8c30d506fb.tar.gz
gentoo-7116780256ba1bf5a294ad8b08c53a8c30d506fb.tar.bz2
gentoo-7116780256ba1bf5a294ad8b08c53a8c30d506fb.zip
gnome-extra/gnome-calculator: ebuild touchups, restrict to <=vala:0.44
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild
index a24f55501a27..94ee7af829fd 100644
--- a/gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+VALA_MAX_API_VERSION="0.44"
inherit gnome.org gnome2-utils meson vala xdg
DESCRIPTION="A calculator application for GNOME"
@@ -15,35 +16,36 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-lin
# gtksourceview vapi definitions in dev-lang/vala itself are too old, and newer vala removes them
# altogether, thus we need them installed by gtksourceview[vala]
RDEPEND="
- >=dev-libs/glib-2.40:2
+ >=dev-libs/glib-2.40.0:2
>=x11-libs/gtk+-3.19.3:3
- x11-libs/gtksourceview:4[vala]
+ >=x11-libs/gtksourceview-4.0.2:4
>=net-libs/libsoup-2.42:2.4
dev-libs/libxml2:2
dev-libs/mpc:=
dev-libs/mpfr:0=
"
-DEPEND="${RDEPEND}
- $(vala_depend)
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-libs/appstream-glib
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
+ $(vala_depend)
+ net-libs/libsoup:2.4[vala]
+ x11-libs/gtksourceview:4[vala]
"
src_prepare() {
- vala_src_prepare
xdg_src_prepare
+ vala_src_prepare
}
pkg_postinst() {
xdg_pkg_postinst
- gnome2_icon_cache_update
gnome2_schemas_update
}
pkg_postrm() {
xdg_pkg_postrm
- gnome2_icon_cache_update
gnome2_schemas_update
}