summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-06-14 11:09:13 +0200
committerPacho Ramos <pacho@gentoo.org>2021-06-14 11:09:40 +0200
commit736ad40e1656cf15d46f02faa39353ff84eb6d86 (patch)
tree5e2064a0082cad0cbd592a2415cd865104f7b64d /gnome-extra
parentapp-editors/amyedit: Remove last-rited package (diff)
downloadgentoo-736ad40e1656cf15d46f02faa39353ff84eb6d86.tar.gz
gentoo-736ad40e1656cf15d46f02faa39353ff84eb6d86.tar.bz2
gentoo-736ad40e1656cf15d46f02faa39353ff84eb6d86.zip
gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen: New snapshot
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210430.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
index e30fbde7c484..781efc194fc8 100644
--- a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20201211.tar.gz 15576 BLAKE2B 142cfb895f9adf2163e36a6005e222897c18e5ca347a9e6958664226abe9f4a6dd1a616b917ccee9531d3f1c27a3e8981a1d3335795543b782736a61b115fe67 SHA512 87efd0e222ba5676caabdff5fdb365e4f769ee4ca15a4718739934b40c3616c031283a1c3883d65dfc75ea59fdb63a9eaf3522465740602f987a136de688b19f
+DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20210430.tar.gz 14854 BLAKE2B 20f1863c14fd1f578e50fdb7d818f7fc03c60833f8129b0300a467f201788b69dc0d405eaa637bc933a3ea69ce480acbadf6dd7ad7d7f4395b814cc53665a1e3 SHA512 64ff64d88a9127d981bc9a2e58fa12d04be723aedc29e172784cdd977bab4828cc6c52a293f11216f6f034e43cef025f83c71ec3cb2ae93d6e90ed77b565c7a5
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210430.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210430.ebuild
new file mode 100644
index 000000000000..b96d7d695928
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210430.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+# Updates are now in 'gnome-shell-40' branch, not 'master'
+COMMIT="b52b79e957222d9a4c0ece35d64fc2dd8d93347d"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+S="${WORKDIR}/Control_Blur_Effect_On_Lock_Screen-${COMMIT}/${extension_uuid}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf LICENSE README.md schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}