summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUwe Scholz <uwescholz@src.gnome.org>2016-10-19 23:30:13 +0200
committerPacho Ramos <pacho@gentoo.org>2016-11-04 10:17:23 +0100
commit7f436be7e89e0ccc7b281b0122862c4223e084c0 (patch)
tree64eaaffb9bfc1fe5522a35bd1d5bdf43c82133e6 /gnome-extra
parentgnome-extra/gnome-commander: Removes incorrect quotes in metadata file (diff)
downloadgentoo-7f436be7e89e0ccc7b281b0122862c4223e084c0.tar.gz
gentoo-7f436be7e89e0ccc7b281b0122862c4223e084c0.tar.bz2
gentoo-7f436be7e89e0ccc7b281b0122862c4223e084c0.zip
gnome-extra/gnome-commander: Version bump to 1.6.1 and update to EAPI=6
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-commander/Manifest1
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild62
-rw-r--r--gnome-extra/gnome-commander/metadata.xml1
3 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/Manifest b/gnome-extra/gnome-commander/Manifest
index 0da6abb384aa..42e35b1f84e6 100644
--- a/gnome-extra/gnome-commander/Manifest
+++ b/gnome-extra/gnome-commander/Manifest
@@ -2,3 +2,4 @@ DIST gnome-commander-1.4.2.tar.xz 6285452 SHA256 8f47ac8428086406536c45b53cbf23b
DIST gnome-commander-1.4.6.tar.xz 6350560 SHA256 55f3dd2ee4295c4b88a5c7810bbbd1db126213871b263dd5a44c0d48e8ef3a01 SHA512 e678234ffa12c4c44213c2a512a993008656e9a918f66d2731ab6f462f4c0345b6b71db72cae90b01309e5f422561cc6a09f631c90d906f49dc39b4f8c8f8ad2 WHIRLPOOL 5d2373a668ca2575726dce2d60134927b970e61e9da6b6c71b07f44dee623d73332eea69ebf95340fed3d324595257f544190db78da9b6d6716ece3ac9cb180e
DIST gnome-commander-1.4.7.tar.xz 6368468 SHA256 54ac33b7df1268a8b1acf18d0b9dda35fa7438e15e2ace0f062e42525528a517 SHA512 3d7a5b00ffa5dd4666322312165670c8a04c6819234d3b3e5e44df2f3fb300ccac1ee8c4fb3961e963786eef543d8a77fcad3454b043dd5943f54d36dadf4403 WHIRLPOOL c6d73d58927bb9f6e224dff107b54047b95609060408b36992b4890318ebcb45a042f5117a3ed121d7fc5b563bbf402237e0a6bf94f684825d7ff0598a4eab23
DIST gnome-commander-1.4.8.tar.xz 6374144 SHA256 7124e9c45d934b0fba95e6721715d07a251e1e2e054d614a3145ad587340de86 SHA512 1b4a6980bff62ce454d6e0952941bacb078c157d5b6a12ee917a849ada89d9d02bb90e92e01eaf6ee4c0487c35251a9591de9cf340c6c2c3f16a2dd853bb6798 WHIRLPOOL 48a01ba8c5f89025b73dc15826cd9bf87ad094a5775bc82861034b37d094b3725c5cc54032ad968d54ca6e9db014d2dd9de4217fa3bd8d5cad1028a4be8cdae0
+DIST gnome-commander-1.6.1.tar.xz 6550308 SHA256 9f796c65b17e7d3a125e8298638d16d3b0ba7ea155371d7b8d413e7f8b4aeee0 SHA512 717e8bb560c6c7e6505cfee1d9ab12f7b3d5c2f8131b9eaf8b15e13aa71dad85574b14ae6f3a42dae42d8a6a291d33cd71db5a4155184bec4f66e3db8b2daab0 WHIRLPOOL 7569ec3bf275754022a19830871bde6139363c1a3d2e1792cff678cee79674d7a6022ba8fa678f9e48a79bebcf36acfd08c75db4f9e3c457e668a2e68c88c1f0
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
new file mode 100644
index 000000000000..ebac3264b930
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm exif gsf pdf python taglib samba test"
+
+RDEPEND="
+ app-text/gnome-doc-utils
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libunique-0.9.3:1
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ samba? ( >=gnome-base/gnome-vfs-2.0.0[samba] )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ taglib? ( >=media-libs/taglib-1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( >=dev-util/cppunit-1.13.2 )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable python) \
+ $(use_with chm libchm) \
+ $(use_with exif exiv2) \
+ $(use_with gsf libgsf) \
+ $(use_with samba) \
+ $(use_with taglib) \
+ $(use_with pdf poppler)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}
diff --git a/gnome-extra/gnome-commander/metadata.xml b/gnome-extra/gnome-commander/metadata.xml
index 7ad4449a1a33..81e6e1995356 100644
--- a/gnome-extra/gnome-commander/metadata.xml
+++ b/gnome-extra/gnome-commander/metadata.xml
@@ -24,6 +24,7 @@
<flag name="gsf">Add metadata support for OLE, OLE2 and ODF</flag>
<flag name="pdf">Add metadata support for PDF</flag>
<flag name="python">Add support for python plugins</flag>
+ <flag name="samba">Add support for SAMBA (Windows File and Printer sharing)</flag>
<flag name="taglib">Add metadata support for ID3, Vorbis, FLAC and APE</flag>
</use>
</pkgmetadata>