summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-08 11:04:17 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-08 11:17:43 -0700
commit857ab7a0781417a9202229f76ddd7483fa9580a1 (patch)
treec0de91d30402aa819576ef4c39e75250c5ac7456 /gnome-extra
parentwww-apps/grafana-bin: Bump to 8.0.0 7.5.7 (diff)
downloadgentoo-857ab7a0781417a9202229f76ddd7483fa9580a1.tar.gz
gentoo-857ab7a0781417a9202229f76ddd7483fa9580a1.tar.bz2
gentoo-857ab7a0781417a9202229f76ddd7483fa9580a1.zip
gnome-extra/gucharmap: Version bump to 13.0.8
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-13.0.8.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 5ca11c7c1a1c..f297aa583a82 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,2 +1,3 @@
DIST gucharmap-13.0.7.tar.gz 1919890 BLAKE2B c90b09f2e52b27ea652a32c4a502a57767eb4f4cf5895a61f3a871f1f5fb81c27083938fc9394d2a74881bfd4c23fdf2cdbce2dc07a55cd3a7d9422e6da40ff9 SHA512 9ed3cea9560cfb53af61863b0811a4d62c347e404880154acd47c5e4148d5b5cf3c31a4ad3b8440081e0bc7b33666c6b0fed35c26f8ee9c0a1746d9ed61b19ca
+DIST gucharmap-13.0.8.tar.gz 1920107 BLAKE2B 247b6683358e1fcbba02cad8146b8b1e7a4ccd5e56d3f9c6e597b47bcd38d11759a02e60d5635c3f2e26defe166b6e4ded696b5d1f6e1be6564d6139e3ed1ab8 SHA512 15eacbf351c8b2357e59913e5b4cccd279aed7a492351c42101dd26020658f2f4d7aaff2a3b95ca340a73606592f47edf9645c93234afb1a086362ef32904bcf
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/gucharmap-13.0.8.ebuild b/gnome-extra/gucharmap/gucharmap-13.0.8.ebuild
new file mode 100644
index 000000000000..8f491c6b3bff
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-13.0.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+UNICODE_VERSION="13.0"
+
+IUSE="debug +introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.19.8
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ vala? ( $(vala_depend) )"
+
+DEPEND="=app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=dev-libs/glib-2.32:2
+ media-libs/freetype:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/pango-1.42.4-r2[introspection?]"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use debug dbg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ meson_src_test
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}