summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-01-29 11:10:14 +0100
committerPacho Ramos <pacho@gentoo.org>2022-01-29 11:42:45 +0100
commit9d6571412d01b724b9cafe4c23c1738a8dfbd8ed (patch)
treea4c21d1b154d6d814ee79263a711ce7da422b67e /gnome-extra
parentsys-cluster/rdma-core: drop versions (diff)
downloadgentoo-9d6571412d01b724b9cafe4c23c1738a8dfbd8ed.tar.gz
gentoo-9d6571412d01b724b9cafe4c23c1738a8dfbd8ed.tar.bz2
gentoo-9d6571412d01b724b9cafe4c23c1738a8dfbd8ed.zip
gnome-extra/gnome-shell-extension-alphabetical-grid: add gnome-shell-extension-alphabetical-grid
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-17.0.ebuild55
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/metadata.xml8
3 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
new file mode 100644
index 000000000000..e84cfbf9beb4
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
@@ -0,0 +1 @@
+DIST gnome-shell-extension-alphabetical-grid-17.0.tar.gz 288368 BLAKE2B 7e22e06538d8804afb8301c40e02bcd1d56f6c756d69bb09d61649bceb6e1819e6cdf1ceb2f1d4e88ee22e92c3a6b465fd925fdde840b9c6124583cc7389a344 SHA512 46d5b7e269d0a454f04fde729fd6d5a66a270a3b2337159fc746d12304c7988846c1fb5c609c9122c3fca25c6110a714766b2f900c7fa1306251750781eff3e5
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-17.0.ebuild b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-17.0.ebuild
new file mode 100644
index 000000000000..429429ac7ad3
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-17.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+# Useful specially to prevent
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4684
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3180
+DESCRIPTION="Restore the alphabetical ordering of the app grid"
+HOMEPAGE="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+SRC_URI="https://github.com/stuarthayhurst/alphabetical-grid-extension/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/alphabetical-grid-extension-${PV}"
+extension_uuid="AlphabeticalAppGrid@stuarthayhurst"
+
+# Not useful for us
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md LICENSE.txt Makefile schemas || die
+ mv -v ui/* . || die # Searches for these files in parent dir
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/metadata.xml b/gnome-extra/gnome-shell-extension-alphabetical-grid/metadata.xml
new file mode 100644
index 000000000000..3947e1bf6d57
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>