summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-08-17 12:07:45 +0200
committerPacho Ramos <pacho@gentoo.org>2020-08-17 12:07:45 +0200
commit9e56f248a0be3a7b00071472b23681f775c66bd7 (patch)
tree43f54753c4027f1f8af24acbc64444150cf1d8bb /gnome-extra
parentsys-process/procps: x86 stable wrt bug #737498 (diff)
downloadgentoo-9e56f248a0be3a7b00071472b23681f775c66bd7.tar.gz
gentoo-9e56f248a0be3a7b00071472b23681f775c66bd7.tar.bz2
gentoo-9e56f248a0be3a7b00071472b23681f775c66bd7.zip
gnome-extra/gnome-shell-extension-gsconnect: Bump to v41
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-gsconnect/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-41.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-gsconnect/Manifest b/gnome-extra/gnome-shell-extension-gsconnect/Manifest
index 9fd555ea404e..b24f98d30c54 100644
--- a/gnome-extra/gnome-shell-extension-gsconnect/Manifest
+++ b/gnome-extra/gnome-shell-extension-gsconnect/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-extension-gsconnect-33.tar.gz 314704 BLAKE2B fa4f2eb6325356a058b24b92b683ca7331af30112d27060e8ee191c21a3269639da58992d53434c7121ea511ee9e07869b082f908b59e19fc2434f3c07e09624 SHA512 26ef929b9b128db0cb29fba22203a3afd500c5b1c3bac6917926a60350d271e67bb0985866f84877355c079fe4a5656b8ac5e8dae976d17d9a068cc825293bce
DIST gnome-shell-extension-gsconnect-39.tar.gz 306878 BLAKE2B 273d2841d39a7786f40062dbc60cbefd48cfa589d91c938c6fdb6e61c3ffefe3621613aa59cb2526165e20fd6f62c526a5150b369f7f8d3fa1d828b05c95d817 SHA512 e62b9acd5ec3fed6be602dfeba747913a8c0d9c243d6b9b67a9c42d635f693c168052957edbcf598869f3dd45e15822c045bf1ac545729da2d45557a47fa85dd
DIST gnome-shell-extension-gsconnect-40.tar.gz 612288 BLAKE2B 6ac6ba5775c64f5bf2ac429c11fca454a18dc17b4fb01b5363ef42a03f318247874e54479d2ccd8640977e4b958c9d45907d075bbe599d5089051e16f8bcd789 SHA512 5635a74d3ac0a15dd49bc844b46de181db7df5ea43931505edcb25f49c50eafeb98d3570c634a5995a3b1632692ee95402eda7fb6086b31b512f6f64df331ab2
+DIST gnome-shell-extension-gsconnect-41.tar.gz 614195 BLAKE2B ebcf9fca448e27fe0e74bf4118528a5f8f7055ea962d4e928feceaa3257e9ff6f286a2b11631468abac1355c2506a0d8923fe56d4370f37fd7e93fe7cd8e8d45 SHA512 12de97683e4bcbf49774b6b6f93803bb0d0005f3114a581ccd7a7219cc2cb27a0e7b10d45a162c879f27e058d99b791ce33425e465651fe1f4e93f1a332a0eaa
diff --git a/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-41.ebuild b/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-41.ebuild
new file mode 100644
index 000000000000..532f48d0ea14
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-41.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="KDE Connect implementation for Gnome Shell"
+HOMEPAGE="https://github.com/andyholmes/gnome-shell-extension-gsconnect"
+SRC_URI="https://github.com/andyholmes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus"
+
+COMMON_DEPEND="dev-libs/glib:2"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=dev-libs/gjs-1.48
+ =gnome-base/gnome-shell-3.36*
+ gnome-base/gvfs
+ gnome-extra/evolution-data-server
+ || ( media-libs/libcanberra media-libs/gsound )
+ nautilus? (
+ dev-python/nautilus-python
+ gnome-base/nautilus[introspection] )
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="For knowing more about how to do the setup, please visit:
+https://github.com/andyholmes/gnome-shell-extension-gsconnect/wiki/Installation"
+
+src_configure() {
+ # nemo support relies on nemo-python from https://github.com/linuxmint/nemo-extensions
+ # https://bugs.gentoo.org/694388
+ meson_src_configure \
+ -Dnemo=false \
+ $(meson_use nautilus)
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}